Jump to content

DCS World 1.5 & 2.0 AMD/ATI Tweaking Guide


Oubaas
 Share

Recommended Posts

After looking around and not finding much specific on settings for my machine, I just spent six (6) hours going through the graphics options for DCS one at a time, trying every setting, trying combinations, until I squeezed out the the last drop of frame rate that I could get while still maintaining acceptable quality.

 

So I thought I'd share what I found to keep you from having to mess around for six (6) hours. I learned some weird things. For example, if I do not set textures to "High" I lose FPS. Strange but true. But even stranger, my machine loves clutter, bushes, and trees. I can't explain it. That's just what happened.

 

I used the L-39C, same flight every time for consistency. Here's my machine's specs:

 

AMD Phenom II X6 1090T 3.2 GHz

ASUS R9280X DC2 TOP @ 1070 MHz GPU, 6400 MHz Memory Clock

16 GB of Corsair DDR3 RAM

1 TB Western Digital 7400 RPM Hard Drive

Sound Blaster XFi Xtreme

TrackIR 5

 

And so on and so forth. Now here's the results of six (6) hours of testing.

 

FINAL UPDATED SETTINGS (See explanatory notes below)

 

DCS Options

 

Textures: High

Terrain Textures: High

Civilian Traffic: Low* (I don't like traffic, thus Low. Works on High.)

Water: High

Visual Range: Medium

Heat Blur: High

Shadows: Flat Only

Resolution: 1920x1080

Res. of CP Displays: 1024

MSAA: 16xQ

HDR: On

Depth of Field: Off (I don't like DoF, you may want it.)

Lens Effects: Off (I don't like lens effects, you may want them.)

Clutter/Grass: 1500 (Max)

Trees Visibility: 25000(Max)

Preload Radius: 150000 (Max)

Anisotropic Filtering: 16x

Flat Terrain Shadows: On

 

All right, so there's the in-game system settings. Now on to the AMD Radeon settings.

 

Anti-aliasing Mode: Enhance Application Settings

Anti-aliasing Method: Multisampling

Morphological Filtering: On

Anisotropic Filtering Mode: Use Application Settings

Texture Filtering Quality: High

Surface Format Optimization: On

Wait for Vertical Refresh: Off, unless application specifies

OpenGL Triple Buffering: Off

Shader Cache: AMD Optimized

Tessellation Mode: AMD Optimized

Frame Rate Target Control: Disabled

 

These settings give me around 60 FPS consistently in DCSW 2.0 and around 40 FPS consistently in DCSW 1.5 in cockpit view with TrackIR 5, with the best image quality I have had thus far since the whole thing began with Lock On. Actually, I flew Flanker 2.0 before that even. I figure the lower FPS in DCSW 1.5 is due to all that water. If you don't mind lesser water quality, you could set it to Medium in DCSW 1.5. As for me, I like pretty water.

 

Shadows are the big frame rate killer for the Radeon. That's all right with me, because I don't like flickering shadows in the cockpit. My image quality is great with the above settings. It looks very good. I had noticed that my AA was jagged lately and overall image quality wasn't good. These settings fixed all that.

 

Before you balk at turning down shadows, try it. Low and Medium shadows don't look too good and do a lot of flickering. You have to set them to at least High for them to look good. If my machine could handle it, I'd blast them up to Ultra. But until I get a new box, this suits me fine. It gives the cockpit a nice clean look with no flickering, and everything else looks very good as well.

 

Well, I hope this helps somebody. I would have liked to have found this info instead of spending six (6) hours experimenting. I'm surprised my head didn't explode. I don't like drudge work, but it had to be done. So I had to share my results. I hope you find the information useful.

 

EDIT: OK, I just did some more testing. For some reason, my game profile for DCS in my Radeon settings was not being used. Instead the game was going for my Global Settings. Having now played with the mess, I have an answer for those who are still suffering low frame rates.

 

Change AA Method to "Multisampling" in your card's game profile for DCS. You might want to do that in your Global settings too, in case your game specific profile is not being used. You can also turn ON the Morphological Filtering. Once you've made these changes within your Radeon card settings, go check your frame rate and your image quality. I think you'll be pleased.

 

Edit 2: One last thing. After fooling around some more, I recommend that you set Anti-aliasing Mode to "Enhance Application Settings". It does seem to add a little refinement to image quality, or maybe it's just my imagination. But you seem to pick up a few FPS that way as well. The big problem with Radeon cards seems to be that DCS hates the AMD implementation of both "Adaptive Multisampling" and "Supersampling". Those two settings are instant frame rate killers. But if you use simply "Multisampling", you can turn pretty much everything else up to full blast and end up with decent frame rates and excellent image quality.

 

BTW, it seems that things have changed as we've progressed along and received updates. My old settings no longer returned the image quality or performance that they once provided. So if you haven't changed your settings in a while and you've noticed that your image quality and performance have dropped, you need to re-do your settings. You might want to give the settings above a try.

 

I've edited the entries above and they now represent my final advice for Radeon card owners. Give them a try, I think you'll like them.

Oubaas :pilotfly:


Edited by Oubaas
Updated findings.
Link to comment
Share on other sites

If anyone actually tries this final, updated list of settings for Radeon cards, please let me know how it worked for you.

 

These settings work great on my machine. It took a lot of testing to get it all wrung out.

 

Oubaas :thumbup:

Link to comment
Share on other sites

Hi Oubaas

 

I tried your original settings yesterday but they dropped my framerate quite dramatically. I only have an old ATI 5770 1GB card so its not very advanced. CPU is an intel i5 running at 3.6 GHz.

 

What I did take from your settings is the issue of the shadows. Turning these up really has a dramatic reduction is FPS. So I set them at Flat Only like you said. Much better performance.

 

Also I cannot use anymore than 4x MSAA. This really kills my framerate if I go any higher.

 

Regarding the AMD Radeon settings, I found your settings further reduced my framerate. I basically have to have everything at its lowest or most basic setting or leave it up to the game itself. I will try the ENHANCE APPLICATION SETTING and Morphological Filtering later tonight and see what that does.

 

Anyway, your post pushed me into messing with my settings and I have as a result increased my FPS by about 8-9 FPS. That is mainly to do with turning shadows to flat and reducing my MSAA setting. These two were the worst offenders.

 

So thank you, I will try tinkering some more and see if I can push up my FPS a few frames more. I need all i can get with my system.

 

My Settings:

 

DCS Options

 

Textures: High

Terrain Textures: High

Civilian Traffic: Off

Water: Low

Visual Range: Medium

Heat Blur: Off

Shadows: Flat Only

Resolution: 1920x1080

Res. of CP Displays: 1024

MSAA: 4x

HDR: Off

Depth of Field: Off

Lens Effects: Off

Clutter/Grass: 300 (Only when flying my Huey, I set this at 0 when flying jets)

Trees Visibility: 7800

Preload Radius: 150000 (Max)

Anisotropic Filtering: 8x

Flat Terrain Shadows: On

 

AMD Radeon settings:

 

Anti-aliasing Mode: Use Application Settings

Anti-aliasing Method: Multisampling

Morphological Filtering: Off

Anisotropic Filtering Mode: Use Application Settings

Texture Filtering Quality: Performance

Surface Format Optimization: Off

Wait for Vertical Refresh: Off, unless application specifies

OpenGL Triple Buffering: Off

Tessellation Mode: Use Application Settings


Edited by Milli
Link to comment
Share on other sites

Thanks for the feedback, Milli. Make sure that in your game profile and under "Global Settings" in your Radeon control panel that you have your antialiasing method set to "Multisampling". Setting it to "Adaptive Multisampling" or "Supersampling" in either place will really kill your frame rate if the game sees it. The DCS engine doesn't seem to like AMD's implementation of those modes.

 

Take a look at my original post, I've updated a few things since I originally posted it.

 

I hope you get things sorted out. If you change things to "Multisampling" and your frame rate suddenly jumps up, you might want to try raising your AA level beyond 4X.

Link to comment
Share on other sites

  • 2 weeks later...

I own an AMD 7770 2g ddr5 I will test what u suggest. But after I make a new fresh install of dcs cause all the back and forth broke the game

 

Mig-21 Headbutter

"These are not the bugs you are looking for..":pilotfly:

 

[sIGPIC][/sIGPIC]

 

My YouTube channel

 

SPECS

-AMD FX8370 8 Core Processor 4.2 ghz

-GIGABYTE 970A-UD3P

-GTX 1050 TI Windforce 4g

-16 GB RAM

-Saitek X 52

-FaceNOIRtrack - 3 point clip Red Led

Link to comment
Share on other sites

Thnx for the guide especially on the AMD software. However my bigger problem is flying over city's. Fps drop dramatically.. Msa 4x, anti. 8x, view dist. Medium. No HDR, fov, or len's. Shadows are flat only.

I remember a post on how to remove number of 3d buildings but no matter how I search I can't find it..

 

Mig-21 Headbutter

"These are not the bugs you are looking for..":pilotfly:

 

[sIGPIC][/sIGPIC]

 

My YouTube channel

 

SPECS

-AMD FX8370 8 Core Processor 4.2 ghz

-GIGABYTE 970A-UD3P

-GTX 1050 TI Windforce 4g

-16 GB RAM

-Saitek X 52

-FaceNOIRtrack - 3 point clip Red Led

Link to comment
Share on other sites

Is this what you are looking for BadHabit?

http://forums.eagle.ru/showpost.php?p=814314&postcount=18

 

You'll find those structures have moved to here now:

DCS World 1.5 Open Beta\Mods\terrains\CaucasusBase\Structures\High\EDM

 

I have an old JSMGE mod of this tweak which I shall adjust to fit the new file structure. When I have time I'll see if it helps with my FPS with these structures removed. I too have a loss of fps when looking at built up areas which is quite distracting.

Link to comment
Share on other sites

Similar yes. It was a lua file,it had options for low medium and high vis range and in it a table with obj within it the structures. I remember I could lower the values and get similar results. Thanks for the info will try.

 

Mig-21 Headbutter

"These are not the bugs you are looking for..":pilotfly:

 

[sIGPIC][/sIGPIC]

 

My YouTube channel

 

SPECS

-AMD FX8370 8 Core Processor 4.2 ghz

-GIGABYTE 970A-UD3P

-GTX 1050 TI Windforce 4g

-16 GB RAM

-Saitek X 52

-FaceNOIRtrack - 3 point clip Red Led

Link to comment
Share on other sites

  • 2 months later...

Great Oubaas,

 

I'm playing DCS on AMD Radeon 7970Ghz Edition + Core i5 2500K @ 4.5Ghz

 

As you said, "Multisampling AA" really gives much better fps than "Adaptive multisampling" so i can raise DCS system graphical configuration higher at 8xQ MSAA

 

Before, I only run DCS at 2x MSAA with Adative multisampling and get lower fps, around 35-51fps

 

With AA setting downgrade to "multisampling" and higher MSAA quality, fps increase around 10fps stably or more, up to 48-60fps


Edited by Majesco



Link to comment
Share on other sites

  • 2 years later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...