Jump to content

Helios + Windows 10 Problem

Recommended Posts

Hi All,


I've been using Helios with Loz's profile for quite some time now to run DCS A-10c; it's always been fun setting it up - but it's always worked in the end.


A little while back I updated to Windows 10 from my 7 install - and around the same time I stopped playing DCS for a while. I came back to it the other day; got everything installed - got everything exported and lined up just fine- I was so excited to start using it tonight; but when I tried to tap on any of the buttons on the TouchScreen - nothing happened. When I used my mouse - it worked fine.


So, I decided to limit the possibilities and exited DCS. Just running the Helios profile itself I get the same results. I can see a small dot where I tap, but Helios doesn't respond; if I use the mouse it works fine.


I've gone out and reassigned the Monitor as the Touch device in Windows, and calibrated it several times. I can run other programs, menus, on screen keyboard and all respond just fine. The issue only seems to occur with Helios itself.


Has anyone run into this before?


Screen: HP L2105tm

OS: Windows 10 Pro x64

GPU: NVidia GTX960

Link to comment
Share on other sites

I was in the same boat as you, returning to DCS after a long layoff. Helios does not like changes and I saw all kinds of strange errors, some unfixable. If an interface just does not seem to work correctly, you probably have to delete and then re-add it. That means redoing all bindings for it.


Like I said, Helios is picky about changes. If you edit and save your Helios profile when your hardware controllers are not loaded or turned on, it will screw up the bindings associated to those controllers.


For my cockpit, if I change the system hardware (new computer, ect), my Helios profile won't work. Backups won't help at that point and a new profile with deleted/re-added interfaces is the only fix. My setup is unique though, as I use so many virtual controllers.


Best of luck to you,

Link to comment
Share on other sites

  • 2 weeks later...



Just wanted to provide an update to this and the resolution for the issue... It seems pretty dumb to me, but hey - it worked.


I was getting pretty frustrated with it, so I decided to see where the issue was coming from by eliminating items one by one. It turned out to be the first item I eliminated that put me on track to resolve the issue.


1. I unplugged the HDMI cable to my TV and just left the TouchScreen itself plugged in on it's own. After creating a test profile in Helios - it worked perfectly.

2. I hooked the TV back up and set the TouchScreen as Monitor #1 and the TV as Monitor #2

3. I then Re-oriented the screens within windows so that my TV was on-top of my TouchScreen.

4. I Reset the monitors within Helios (Which wouldn't work properly so I had to open a second Helios Editor and Copy/Paste everything into a new Profile)

5. Saved and launched - everything works perfectly.


I haven't had an issue with it since. Hopefully my experience can help someone who finds this post down the road.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...