Jump to content

[RESOLVED]Cyclic stuck to 100%


Recommended Posts

Hi, I cannot get the cyclic to lower and I always crash, it's set to the default key bindings (numpad - for lower and numpad+). i reset to default, I repaired DCS world 2.03


I'm using track ir5 and Logitech 3d pro,


it has worked for me before


any thoughts?



Edited by BIGNEWY
Link to comment
Share on other sites

  • ED Team

Hi and welcome to the forum


Check your stick in windows, make sure it is calibrated.


also in game use Rctrl + enter so your can see you axis working while flying to check.


check other control columns to make sure you have no conflict


failing that try a fresh set of controls


C:\Users\yourname\Saved Games\DCS\Config\Input and delete the aircraft folder you wish to redo, and then redo your controls ingame.


let us know how you get on

Edited by BIGNEWY


Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 64GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

Have you looked at the axis control settings, and deleted all the unwanted entries? When you first run a new module, it is the first step to take. You will find all controllers have entries for all axes, and you need to delete all but those that are required. i.e. Pitch and roll for the joystick, thrust for the throttle, rudder to the rudder pedals etc etc. (That is what BIGNEWY was referring to as conflicts).

  • Like 1
Link to comment
Share on other sites

Hi Bignewy & NeilWillis,thank you for the quick reply, I ended up deleting the input and checking the axis and it now works fine. I never would have figured it out without the help you both provided. Thank you soo much

You guys Rock!!


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...