Jump to content

Missile's wont select/fire (Re)Arm Bug? (Multiplayer)


OnlyforDCS
 Share

Recommended Posts

Hi,

 

After a succesful sortie on Blue Flag (just now) taking out two enemy fighters, landing at homebase, refeuling and rearming, my weapons on the Mirage stopped being functional. Target was locked, Master arm was on, missiles were selected, however the HUD was unchanged from the navigational mode. Missiles wouldn't fire on an enemy no matter what I did.

 

User error or Bug? Im pretty sure it wasn't user error, unless Im missing some procedures after rearming.

 

*edit*

 

This was on 1.5.6. release version. Buddyspike Blue Flag server.

Current specs: Windows 10 Home 64bit, i5-9600K @ 3.7 Ghz, 32GB DDR4 RAM, 1TB Samsung EVO 860 M.2 SSD, GAINWARD RTX2060 6GB, Oculus Rift S, MS FFB2 Sidewinder + Warthog Throttle Quadrant, Saitek Pro rudder pedals.

Link to comment
Share on other sites

Next time it happens, toggle your masterarm off and on again. What basically is happening is the re-arm resets your masterarm to off. But you probably got a switch bound to it, which is resetting it back to on. Without resetting it.

 

Ergo, on some cases you will see the switch in the upward position visually, while under the hood it is turned off.

 

Best way to avoid it is to turn your masterarm off before re-arm. I have had this before, but since I started turning off my arm before arming ,haven't seen it again.

 

Yes this might very well be it. Thanks. :thumbup:

Current specs: Windows 10 Home 64bit, i5-9600K @ 3.7 Ghz, 32GB DDR4 RAM, 1TB Samsung EVO 860 M.2 SSD, GAINWARD RTX2060 6GB, Oculus Rift S, MS FFB2 Sidewinder + Warthog Throttle Quadrant, Saitek Pro rudder pedals.

Link to comment
Share on other sites

Wait, I just remembered. I landed using the APP landing approach mode, which means my MASTER ARM had to be set to off.

 

The track is quite big (65 MB) and for some reason I can't upload it.

Current specs: Windows 10 Home 64bit, i5-9600K @ 3.7 Ghz, 32GB DDR4 RAM, 1TB Samsung EVO 860 M.2 SSD, GAINWARD RTX2060 6GB, Oculus Rift S, MS FFB2 Sidewinder + Warthog Throttle Quadrant, Saitek Pro rudder pedals.

Link to comment
Share on other sites

Wait, I just remembered. I landed using the APP landing approach mode, which means my MASTER ARM had to be set to off.

 

The track is quite big (65 MB) and for some reason I can't upload it.

 

Sorry to hear about that because the track is invaluable to debug the problem.

Perhaps you can upload it to something like dropbox and share it.

"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning."

"The three most dangerous things in the world are a programmer with a soldering iron, a hardware type with a program patch and a user with an idea."

Link to comment
Share on other sites

Sorry to hear about that because the track is invaluable to debug the problem.

Perhaps you can upload it to something like dropbox and share it.

 

Thanks for the reply Zeus, here is the dropbox link:

 

https://www.dropbox.com/s/qoo120kcwl8skwd/Operation%20Blue%20Flag%20ver5.6MorR-20170308-185948.trk?dl=0

 

It's quite long unfortunately. First sortie was a mutual kill with another enemy Mirage (I think). Second sortie, eliminated two bandits, landed at base, refueled and rearmed, and then when locking up an enemy the problems started, even after flipping the master arm on and off, still couldn't get missiles off the rail, and then got shot down as a result.

 

If someone could take a look, I'd be much obliged. Thank you.

Current specs: Windows 10 Home 64bit, i5-9600K @ 3.7 Ghz, 32GB DDR4 RAM, 1TB Samsung EVO 860 M.2 SSD, GAINWARD RTX2060 6GB, Oculus Rift S, MS FFB2 Sidewinder + Warthog Throttle Quadrant, Saitek Pro rudder pedals.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...