Jump to content

[REPORTED]coalition.addGroup cannot hide new groups?


Recommended Posts

@Grimes, is this already reported to ED?

 

When using coalition.addGroup(), it seems that new spawned groups are not hidden, although the "hidden" flag is set on.

 

Do you have the same experience, (and others)?

 

FC


Edited by BIGNEWY
TITLE

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

Seems to be working, tested with 1.5 and tester version on an aircraft group. Can you attach a simple mission where it doesn't work or just post the group table used to spawn the group?

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

Seems to be working, tested with 1.5 and tester version on an aircraft group. Can you attach a simple mission where it doesn't work or just post the group table used to spawn the group?

 

Thanks for your response.

 

To be honest, I am a bit puzzled about this.

 

So, the issue is about spawning new groups eh, not respawning existing alive groups ( = teleporting ).

 

I got a issue logged in our MOOSE community that new spawned groups are not "hidden", although the hidden flag is set on.

MOOSE copies the exact group definition (of the ME) into the addGroup method.But the MOOSE logic is not touching the hidden flag at all.

 

MOOSE touches the following flags:

 

- lateActivation

- visible (only for ground units)

 

To be honest, I haven't really invested time myself in deepening the root cause of this issue, but will do now.

I will come back later with either a confirmation that the issue was found in the MOOSE code or maybe that I need some help.

 

Talk to you.

 

FC

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

@Grimes,

 

The hidden flag is indeed working for spawned units, also in the MOOSE framework.

 

This issue must be with multi player I think. I need to further validate with the mission designer what the exact error was that he experienced. I know that in multi player, hidden spawned units appear on the map (but don't remember the exact scenario).

 

Sven

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

@Grimes after a more thorough investigation this problem has become more clear what the mission designer meant ... The problem regards to multi player.

 

Hidden units do show up on the map view on client machine, although they are "hidden" when you check the map view on the server side.

afbeelding.png

 

To resimulate:

 

1. Please run the attached mission on a server.

2. Connect with a client machine to the server.

3. On the client, select briefing (as spectator) and "fly".

4. Press F10, and you'll see a watch tower and a launcher.

5. Do the same on the server, and you'll see the luancher is hidden on the map view.

 

Problem: On the client machine, the launcher should be hidden on the map.

 

If you run this mission in Single Player, the launcher is also hidden.

 

For completeness, I am also adding there the bug report on github:

https://github.com/FlightControl-Master/MOOSE/issues/676

 

Feel free to chime in if you see it as useful.

SPA-026 - Ground Ops - Spawn RandomizeTemplate Hidden.miz

SPA-026 - Ground Ops - Spawn RandomizeTemplate Hidden.lua


Edited by FlightControl

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

I have begun to use MOOSE in my missions and I can also confirm this bug

METAR weather for DCS World missions

 

Guide to help out new DCS MOOSE Users -> HERE

Havoc Company Dedicated server info Connect IP: 94.23.215.203

SRS enabled - freqs - Main = 243, A2A = 244, A2G = 245

Please contact me HERE if you have any server feedback or METAR issues/requests

Link to comment
Share on other sites

Seems to be working, tested with 1.5 and tester version on an aircraft group. Can you attach a simple mission where it doesn't work or just post the group table used to spawn the group?

 

Could you resimulate it Grimes? What's your take in this?

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

Thank you Grimes!!! Great to get this feedback.

Maybe change the title also to [REPORTED]. So the community knows too.

 

Thanks again.

[TABLE][sIGPIC][/sIGPIC]|

[/TABLE]

Link to comment
Share on other sites

Ooops forgot to mention

 

The problem when a mission is hosted on a "dedicated" and objects are NOT

hidden even though hidden is ticked also applies to static objects

 

If I place a FARP ammo for example and set it hidden when the mission is played on a dedicated server you can F10 map view and see the FARP ammo

METAR weather for DCS World missions

 

Guide to help out new DCS MOOSE Users -> HERE

Havoc Company Dedicated server info Connect IP: 94.23.215.203

SRS enabled - freqs - Main = 243, A2A = 244, A2G = 245

Please contact me HERE if you have any server feedback or METAR issues/requests

Link to comment
Share on other sites

  • 7 months later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...