Jump to content

Trim problem with FFB activated


Gromit (LO-L)
 Share

Go to solution Solved by Torbernite,

Recommended Posts

Hi guys,

A little help required to resolve a trim issue on the Spit IX flight model.

 

With FFB activated in control menu the pitch trim is out of range, by that I mean I cannot trim the aircraft enough to prevent nose up pitching despite using FULL nose down trim.

This is with zero input from the joystick, I have even set the dead zones to high levels to ensure the joystick is not putting any inputs into the flight model.

 

This problem does NOT exist with the rudder trim.

 

If I untick the FFB box the problem dissapears, also if I load up the TF51 model the problem does not exist, I am able to trim the TF51 hands off, so the issue seems to be related to the Spitfire model only.

 

This is making the model unusable so would like to know if there is a patch or work round to prevent this bug.

 

Many thanks

MIke.

 

 

Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

Same problem with A-10C II and F-5E, I'm using a G940.

 

update:

I might have solved that.

According to this post

Stick not centered with 0 input - Controller Questions and Bugs - ED Forums (eagle.ru)

(sorry I don't know how to cite it more beautifully)

the problem comes up when:

1. the mod support FFB;

2. the stick is set with "centering spring force" or a non-zero curvature;

3. the aircraft itself has an asymmetric y axis range(different range in positive and negative directions, that's to say the zero position is not in the center of whole range).

When these factors come together, we get different zero positions for the physical FFB joystick and the "stick" on the plane. When the joystick is released back to center, the "stick" in the game would never be in center.

So just disable the "centering spring force" option in the profiler(or something like that name, I'm not an English speaker, not using EN version profiler and don't know the EN expression for this option),and use a purely linear curve, this problem should be solved.

You might have a try but I'm not sure if it also works with spit 9. I don't have a spitfire and just came here by searching "FFB trimming problem".

 


Edited by Torbernite
Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...

 

I posted this as a Mosquito problem. I think it is the same as the problem that started this thread. I have inverted the FFB axis. I know my FFB2 is working correctly too.

I also have a problem with my FF2.  It works great with the P-51.  All of the axis stay centered.  But when I use the same settings in the Mos, the Y axis is off center.  I can move the full Y axis and it never goes back to center.  This makes it hard to trim the pitch as stick inputs make the nose bounce up and down. The X and Z axis are always centered.

EDIT:  The black square that shows the joystick position always returns to zero.  The red dot does not.  The red dot is to the left of center, on the negative part of the curve. (Curve goes down)  This makes the total width of the red dot's center travel unequal.  There is more on the left side.

  • Like 1
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...