Jump to content

Saitek x45 stick problem

Recommended Posts



If you look closely at the base of the stick (just beneath the stick) that causes it to center... at that point whenever I slightly pull or push the stick, it causes friction and the stick gets very jerky and I can't move it smoothly...


If I pull or push the stick very fast, then I can do it quite smoothly but If try to move it slowly, it causes alot of friction in the base....


I'm not sure that if the internel of the joystick is causing this...


I tried using machine oil there(at the base) but it didnt work....


does this ever happened to you? any suggestions?



Link to comment
Share on other sites

Hi, I had the same problem, what I did was take it apart, and use emery paper on the shaft where the slider moves.

I then bought some graphite grease, and applied it to the slimmed down area, much better on small movements now. You might like to reduce the spring strength a little by clamping a plastic tie around a couple of the top spring coils, if you are happy with this then you can consider shortening the spring slowly.

I can't even get my x45 to operate since .8 upgrade, it worked before but will not be recognised by the slim, I also had a problem with the rudder and joystick, only giving 50% movement, so am waiting to see if any later upgraded improve the situation , or do I have to go for the 'proper controls'!

It may be due to me using XP windows.

cheers David

Link to comment
Share on other sites

To overcome the friction problem, I used cable ties to "shorten" the spring. More detailed, I used the cable ties to bind two windings of the spring together on each side of the stick. This releases pressure from the plastic plate that actually centers the stick and makes the stick movement much smoother but also reduces the amount of force needed to move the stick.

Link to comment
Share on other sites

  • 1 month later...

x45 installation problems


Hi All,


Just wondering if anybody on here has had problems when installing the x45 drivers on XP (32 bit)


I have owned my x45 for since 2002 and it has never given any problems. I have had my x45 in storage for the last year and have tried installing it on my new pc last night.


When you have to plug in the x45 for detection XP states that the joystick does not pass windows compatibility. I checked this on the windows compatibility website and it states that there should be no problem


I then select to ignore this and when I get to the configuration page (where you have to move the joystick through its axis) is where the problem starts. all the buttons work, but the joystick will not register any movement through any of its axis or any of the rotary switches.... All the buttons does work however (I checked this in Microsoft Flight Simulator)


Anybody have any advice?


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...