Jump to content

DCS World Saitek X-52 Profile


Recommended Posts

I have both the DCS A-10C and DCS KA-50 2 standlone games..... i have Saitek x52 profiles for games . when i try using the them profile in DCS World only so function work.... I have made new profile and same thing happen, part of the profile function work. Is there anything i can do to correct problem

 

Foxbat

Link to comment
Share on other sites

While we on the topic of the X52. How the hell do you fix the crashing and stalling of the Profiler and SST? I load JackBauers profile and it works for 5 seconds, then I deactivate it and activate it again and it stops working and hangs. Shortening the key names doesn't seem to help. Done plenty clean re-installs.

 

I know Saitek software is complete poop but this is really starting to piss me off. I want to use my slider and thumb mouse. :mad:

RimOnBlue.png

F/A-18C - A-10C - FC3 - L-39C/ZA - Ka-50 - UH-1H - Mi-8MTV2 - F-86F - Spitfire - P-51D - P-47D - BF-109K - CA

Link to comment
Share on other sites

hi,

 

firs tof al I am not saying other people profile are good, bad, etc.. in fact anyone who works har ona a profile and offers it up deserves thanx... big time specially to those who ar enew to Saitek... and find it a difficult task..

 

I have been using Saitek many years and have had many Saitek sticks.. (HOTAS). But, often, I find that the only profile I am satisifed with turns out to be my own. One big problem is after a while the sticks wear and they spike. Period.

 

yes I know they have pots that are not supposed to spike, but whatever they are, they wear out.. and then you get al kinds of funny (sad) things happening. The you a choice with most games, flight sims, etc... to either program the SST stick software, or in-game controls, or both....

 

That's the way it is with Saitek sticks..... whent they are new they are pretty nice, but as they wear.... or with time, or both, the problems happen...

that's just the way it is...

 

If someone has aprofile that you want but have problems, try to tweak it... you might still get to use it with some slight mods to the profile. Either that or put the time in and program your controls,, it usually takes a long time to get them just right.. not just an hour or 2,3, 8,10. It takes weeks and months of tweaking.

 

IMHO

 

btw, keep back-up copies of profiles..

:doh:

ASUS Z170, WartHog HOTAS and MFG Crosswind

G.Skill 32 GB, Samsung 1TB SSD

EVGA Nvidia RTX 2080-TI

 

 

Link to comment
Share on other sites

I have both the DCS A-10C and DCS KA-50 2 standlone games..... i have Saitek x52 profiles for games . when i try using the them profile in DCS World only so function work.... I have made new profile and same thing happen, part of the profile function work. Is there anything i can do to correct problem

 

Foxbat

 

Hi

 

I used to have those kind of problems with my SST profiles, and I found out I had two different problems that made my X-52 not to work correctly.

 

I think that you should first check that there's no double button assignment both in SST software and internal DCSW profile. I had set the same button in two different ways, one in SST software and the other one inside DSCW, and of course that only caused me problems (I didn't know that some joystick buttons were already assigned to a command or function in DCSW, so even if you never assigned any button in DCSW, you should check if there is any conflict).

 

The other thing I found that caused me problems, is modifiers setup/configuration In the Options Control Menu in DCSW. I used to import my X-52 settings after installing a new DCS update, so I didn't have to go through the whole process again, and since DCSW was released, I always had to check out if modifiers were correctly set. I found several times (if not all of them) that I had highlighted in red color every button combination I had assigned with a modifier, showing that something wasn't correctly set. (I use pinkie button as a modifier, but it wasn't listed as a modifier). I had to set my pinkie switch as a modifier again, and that solved the problem.

 

Besides that, I haven't had any issue with my X-52 and it's working perfectly now, with both SST software running and JackBauer's profile set as default.

 

Hope it helps.

[sIGPIC][/sIGPIC]

 

MSI GT72 6QD Core i7 6700HQ 2.6GHz-3.5GHz - 16 GB DDR4 RAM, NVidia GTX970M 3GB DDR5 - 256 GB M.2. SATA SSD + 1TB HDD 7200 RPM - 17.3" 1920 x 1080 Full-HD IPS Screen - Trackir 5 - HOTAS Warthog

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...