Jump to content

Trying to activate a unit more than once.


Derk
 Share

Recommended Posts

Hi there,

 

I'm still pretty new to the mission editor and need some help on the following:

 

I noticed i can't make an aircraft take-off again after it has landed, but i want to have this aircraft make several runs, much like the way helicopters can do now with the 'land' function. I was able to build a simple ferry type flight using this and have the helicopter move flag values from one zone (and flag) to another. Now i want an aircraft to land at an airport, transver the assigned value to a flag, then after some time have it reset to its original position to simulate another flight of supplies coming in.

I got the flight working so far, but after i deactivate the unit, it won't activate again, it just dissapears for the remainder of the mission. Is this a limitation to the trigger system or is it me?

I have the activation looking continuously for the condition of flag 2 = off, wich is set on mission start (to allow first activation, wich works and also sets flag 2 = on), deactivation and upon death, but she won't re-activate.

 

Thanks for putting up with my questions.

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Once a group is de-activated it cannot be activated again. This is a limitation of the miz editor. The best you can do to simulate is to note where it taxied into and shuts down then deactivate it and immediately activate a new unit in its place.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...