Jump to content

This is embarrasing.. Please Help!!!

Recommended Posts

Hi everyone.


Recently I tried to edit a Lua file, but as I opened it ( or tried to), I got a message choose which program to open. I chose notepad, and now ( i havent edited the file) My game is a bit, no very strange. My apologies for this stupid mistake, and I already know I shouldnt be messing with scripts. Could someone notify me on how to change the file types back. ( They are still listed as LUA files, but when I click on them they open in notepad.






Link to comment
Share on other sites

Can you just rename the file .lua ????

Dusty Rhodes


Play HARD, Play FAIR, Play TO WIN


Win 7 Professional 64 Bit / Intel i7 4790 Devils Canyon, 4.0 GIG /ASUS Maximus VII Formula Motherboard/ ASUS GTX 1080 8 GB/ 32 Gigs of RAM / Thrustmaster HOTAS Warthog / TrackIR 5 / 2 Cougar MFD's / Saitek Combat Pedals/ DSD Button Box FLT-1

Link to comment
Share on other sites

Right-click, select "Open with".


Do not open it with notepad. Ever. Notepad++ (google) is good, and free software.


To diagnose the issues we'd have to have a lot more details on the system though and the specific nature of the strangeness.


Also, Dusty, since the files are still listed as LUA the .lua is still there. The issue seems like he selected notepad as the default utility for them (which should not affect DCS unless he actually saves a file using Notepad and gets the encoding all wonky). Selecting Notepad as the default editor for LUA files does not turn them into .txt's.


Daniel "EtherealN" Agorander | Даниэль "эфирныйн" Агорандер

Intel i7 2600K @ 4.4GHz, ASUS Sabertooth P67, 8GB Corsair Vengeance @ 1600MHz, ASUS GTX 560Ti DirectCU II 1GB, Samsung 830series 512GB SSD, Corsair AX850w, two BENQ screens and TM HOTAS Warthog

DCS: A-10C Warthog FAQ | DCS: P-51D FAQ | Remember to read the Forum Rules |

| Life of a Game Tester
Link to comment
Share on other sites

Unless you actually saved the files after opening, it should make absolutely no difference whatsoever what the default program associated with them is. The program association simply can not and will not affect anything in DCS. If somehow this is false I will eat my hat. So, either you're seeing things, or the "strange behavior" is a different issue altogether.

Link to comment
Share on other sites

what file did you change.


how is the game behaving.



Edited by joey45

The only way to make sense out of change is to plunge into it, move with it, and join the dance.

"Me, the 13th Duke of Wybourne, here on the ED forums at 3 'o' clock in the morning, with my reputation. Are they mad.."


Link to comment
Share on other sites

Right, I guess the problem is that I changed the file ( it was HMS colour) just a single line to green, and resaved it. Started DCS, didn't have a cockpit, but all flight controls still worked. Shut down DCS, changed file back EXACTLY how it was ( the file is C/Program Files/Eagle Dynamics/KA-50/Scripts/Aircrafts/KA-50/Cockpit/Materials.lua) , restarted DCS, and it was the same problem. Thanks evryone for your help - I will explain in a bit more detail. I'm pretty sure this isn't a problem with the PC or DCS itself, but the files unless it was an extraordinary coincidence that at the exact moment I changed the files I got that problem. The problem is in game ( the menus seem to be fine) I had the model, and external views were fine, just the cockpit seemed to be completely missing. I can't really explain it better than that. Mabye the easiest solution would be if I PM someone my email and you send me the materials file???



I hope that clarifies the issue a bit more, althought re-reading the post makes me think I've just complicated it. By the way, if you're having problems with frame rates, wiping the cockpit really helps... does offer some problems with playabilty :P

Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...