Jump to content

Group stop + Group Resume = Slow speed?


EasyEB
 Share

Recommended Posts

Hi!

 

I have a mission set up where the player is to provide CAS for a moving convoy that is driving On Road along set waypoints at 40mph. The player has the ability to stop and resume the convoy via F10 radio command. However, when the convoy is resumed they move very slow (11 mph) and they don't follow the normal Move On Road-type of formation.

 

It is as if the lead vehicle is driving in some kind of combat off road mode on the road and the rest whenever the lead vehicle turn the convoy start to turn off the road to keep the line formation.¨

 

I have it set up like this:

 

Triggers:

1. Mission Start > Group Alive (Player group) > Radio Item Add "Start Convoy" Flag 1 Value 1.

2. Mission Start > Group Alive (Player Group) > Radio Item Add "Stop Convoy" Flag 1 Value 2.

3. Continous Action > Flag Equals (Flag 1 Value 1) > Group Resume (Convoy Group)

4. Continous Action > Flag Equals (Flag 1 Value 2) > Group Stop (Convoy Group)

 

Is there any other way to do this that does not make the convoy snail forward after the Resume command is given?

 

Cheers!

Link to comment
Share on other sites

in 3. below the group resume (convoy group) command insert a set flag 1 to value 0 command.

 

Currently you are continuously sending a group resume command whilst the flag equals 1 which might be affecting the group. If this doesn't work then it may be a bug and someone will look into it.

i7-7700K : 16Gb DDR4 2800 Mhz : Asus Mobo : 2TB HDD : Intel 520 SSD 240gb : RTX 2080ti: Win10 64pro : Dx10 : TrackiR4 : TM Warthog : ASUS ROG SWIFT PG348Q

Link to comment
Share on other sites

Hi!

 

I have a mission set up where the player is to provide CAS for a moving convoy that is driving On Road along set waypoints at 40mph. The player has the ability to stop and resume the convoy via F10 radio command. However, when the convoy is resumed they move very slow (11 mph) and they don't follow the normal Move On Road-type of formation.

 

It is as if the lead vehicle is driving in some kind of combat off road mode on the road and the rest whenever the lead vehicle turn the convoy start to turn off the road to keep the line formation.¨

 

 

Just confirming.

 

I have seen the same issue with the A-10c single player mission (Serpents Head), you have a group of vehicles that scatter from one point after you bomb their command bunker and they take various on road routes and then end up on the same route to their final destinations set to onroad, They all use a group stop / start action to get them going.

 

Original mission and non of the vehicles ever actually make it to their final destination, as they go spazo at different parts of the journey and divert off road and into a pattern similiar to the dispersion under fire type (However they aren't under fire, and I placed a command to disable that reaction anyway).

 

The problem seem to be the fact that:

 

  • Either having more than one vehicle group traversing the same piece of road causes them to get their waypoints mixed up.
  • That the Group start / Stop and Group AI ON / OFF command has some part to play in the error.

I did manage to fix the command truck and a couple of the other vehicle groups from doing this faulty behaviour by adding new vehicle groups and a whole set of new waypoints programmed exactly the same as the original ones and then deleted the originals.

 

 

But a group or two of the jeep groups still run off road and stop there.

 

As for convoys running slow, I have noticed that also, you can have a abrams battle tank group at say 60kph (not sure they can travel that fast in real life or not, but editor allows it)at all on road waypoints and it will only travel at 40kph or slower and when it has to take a 90 degreee corner it will slow to 11kph.

 

Regards, Ian.


Edited by MadDog-IC
some incorrect information

Asus p877v-pro, Intel I7 3770k 4.2ghz, 32gb Ripjaw X ram, Nvidia RTX-2070 Super, Samsung 32" TV, Saitek x52 pro Joystick and Combat rudder pedals, TrackIR 5, Win8.1 x64 with SSD and SSHD protected by (Avast AV).

 

DCS Tech Support.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...