Jump to content

Problem with fixing a target waypoint using radar


Recommended Posts

I'm having difficulty making a position fix of a target waypoint using the radar. I watched xxJohnxx's navigation video

and tried to replicate what he was doing at approximately 18:49.


In my case, the T0 trigger didn't do anything, I had to hit T1 (which is also what I see in the beta manual on page 159 for doing an own-fix (i.e. T1-TV-T1), so I'm wondering if John meant T1 in his video.


In any case, when I do the sequence (with the radar on, and sweeping):

- T1

- Move the radar cursor to the new position

- TV

- T1


I suddenly see the grid lines like I see in John's video, but the waypoint circle does not move to the new location.


I'm wondering if there's anything else I need to do to allow the radar to update the waypoint. I heard John say something about "if we disable editing" around 18:58; Do I have to enable editing of waypoints first via CK37 inputs?


Any help would be appreciated, as without being able to fix target waypoints I would think the BK90 would be useless, among other things.




Link to comment
Share on other sites

John made a bit of an error in his videos, because of the 3 position switch mapping terminology he had the nomenclature wrong. T0 is "unpressed", T1 is first detent (allows slewing), and TV is second detent and makes fixes.

Intel 9600K@4.9GHz, Asus Z390, 32GB DDR4, EVGA RTX 3070, Custom Water Cooling, 970 EVO 1TB NVMe

34" UltraWide 3440x1440 Curved Monitor, 21" Touch Screen MFD monitor, TIR5

My Pit Build, VKB Gunfighter Pro w/WH Grip, TMWH Throttle, MFG Crosswinds W/Combat Pedals, Cougar MFDs, Custom A-10C panels, Custom Helo Collective, SimShaker with Transducer

Link to comment
Share on other sites

It depends on what binds you're using, T0 is the unpressed state, T1 is the first stage on the trigger, TV is the second.

Holding T1 will prepare for a fix and bring the symbology up, pressing TV does the fix, at which point you would release the trigger to T0.


The default binds are a little weird, you have three binds, one for each state. To do a fix you would simply press T1, slew the cross to where you want it then press the TV bind. Fix complete.

For the 3 position binds you keep it in T0, move it to the middle T1 when you want to do a fix, slew the cross to where you want then move it to the TV position. Fix is done, move it back to T0.

Edited by Vladinsky
Link to comment
Share on other sites

OK thanks guys, you're clearing things up a little, as I was a little uncertain about how to handle the three position switch mappings.


I don't have a three way button, so I have mapped all three T positions to separate joystick controls (buttons or a hat position):






So do I even need T0 mapped? Sounds like it should work by just hitting T1, slewing, then TV. One last question then is, do I need to hold the T1 key/button while I'm slewing the radar, then let go and press TV to bind it?



Link to comment
Share on other sites

Hmm, well it still doesn't work for me. As mentioned, after hitting T1 (hat switch down), I get the cross hair, and can slew it (throttle hat switch up/down/left/right). Then I hit TV (js button) and I see the grid appear (i.e. concentric half circles with 3 lines going out from the bottom center towards the top/top-left/top-right), but the waypoint circle does not move from it's original position.


Getting frustrated as I really want to try the Bk90 but I want to be able to adjust the target way point on the fly...

Link to comment
Share on other sites

I know for a fact that I've had this exact thing happen to me before but I can't replicate it now. Does it still not work if you do an air start?


Good point - actually, I have been doing airstarts where this is happening. And I just realized the data cartridge isn't in (at least graphically when I look back there), although the waypoints are seemingly loaded into the CK37 as I can select them. Maybe it's an air start bug?


I'll try it with a ground spawn and see what happens, thanks.

Link to comment
Share on other sites

Is the waypoint correctly set as a target waypoint, i.e. does it show as Mn when selected? If it's a navigation point then taking a fix will update the aircraft own-position.


Yes, it was a target waypoint. Originally a nav point (i.e. B2), but using the CK37 I put into TAKT/input, entered 9 and then hit the B2 button and the destination changed to M2.


In any case, I have an update - after I re-spawned in a ground start Viggen and went through the normal start up procedure, then changed nav point B2 to M2 and took off and tried it, it worked OK this time when I hit T1 / slew cross-hairs / TV (i.e. the waypoint circle in the radar display moved to the new position).


So I think it's an air start bug of some sort.


Thanks for the help, it verified things anyway :).

Edited by 609_Relentov
Link to comment
Share on other sites

I actually had this happen to me once last night. It happened on a cold start for me though. The only thing I can add is that when I pressed T1 I got the radar cross and I could slew it but the destination indicator did not change from M3 to the flashing E3 that you usually get after pressing T1. I had set waypoint 3 as the target waypoint. It seemed like the T1 input was being received by the radar system but not the CK37 maybe? I'm gonna do some more testing to see if I can duplicate it again. This was a mission that I made for myself and had played many times with no failures of this type.

Link to comment
Share on other sites

  • 5 months later...

From page 114 of the Viggen flight manual (beta):


Radar controls


AS-mode selector: Toggles anti-jamming filters.

Passive radar mode selector: ON / OFF. Toggles passive search.

Pulse length selector / PULS/ NORMAL KORT: Toggles pulse length to compensate for brief


Master mode selector:

BER, radar off, but pre-warmed.

NAV, Radar display possible, but only after 180 seconds after main generator comes online.

Search mode.

ANF: Radar function dependent on selected weapon.

SPA/ LANDN NAV/ LANDN P/O. Same function as NAV.

LAND / SEA (LAND / SJÖ): Please refer to navigation section. Changes the signal modulation

on the radar altimeter.

LIN/ LOG: Selects Linear or logarithmic processing of the radar receiver.

RR TILL: No function. Used to override electrical errors.

Radar control stick: Used to move radar cursor (or Cross / circle markers)

Terrain avoidance mode switch: Enables Terrain Avoidance mode, reset when radar is set to A0

Radar mode selector: Three position switch on top of radar control stick.

A0: Switch forward. Radar off.

A1: Switch in middle position. Radar On. Wide search mode with Sector PPI

A2: Switch aft. Radar on. Narrow Search. B-scope

Radar range selector: Increases / decreases radar scan range. Range indicated on bottom of

Central Indicator.

Fix trigger: Used for taking fixes (Visual or radar-based) as well as locking targets during Airto-

Air use.

T0: Neutral position

T1: First trigger detent (rebounding to T0)

TV: Second trigger detent (rebounding to T0)

Memory picture switch Turns radar antenna off but saves current radar picture. Memory mode

will reset when radar mode switch is moved to A0 or A2 or enabling Terrain avoidance mode.

Antenna elevation potentiometer: During search modes the antenna can be steered in elevation

slightly. Has a middle “snap” position.

MKR potentiometer: Regulates the amplification gain of the radar. Has a centre “snap” position

for the best contrast against naval contacts.

Link to comment
Share on other sites

  • 1 year later...

this driving me crazy too.. T1-TV, and slewing with a cross I can't see even when set to proper settings,, if I set the radar to BER I can find the cross easier, but it is almost always hidden off the scope.... then slew it, but lock it before it jumps out..... not sure if it is because of the old Saitek stick, or what not, wish I could enlarge the cross, change color, etc. to see it... it seems that in the past a lot of stuff on this aircraft ( and others) worked better before the massive upgrades and patches... of I have to spend a lot on a new stick... (need new stick, but not until I have lots of extra cash.... LOL.... sad :( ). :joystick:

ASUS Z170, WartHog HOTAS and MFG Crosswind

G.Skill 32 GB, Samsung 1TB SSD

EVGA Nvidia RTX 2080-TI



Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...