Jump to content

Autopilot Pitch/Roll Not Working


Recommended Posts

hey all - i've written about this issue before but never got a solution. I tried it again in 2.5 and it's still happening.

 

situation: starting the elbrus rescue missions for Uh-1h, just switch the hot start version to the Mi-8. immediately the pitch/roll button won't turn on. it'll flash for a second but then stays dark. anyone else able to reproduce this?

 

edit 1: i did the auto-shutdown and then auto-start to make sure it wasn't messing with something, but even then the autopilot channel won't active... :(


Edited by dresoccer4

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

Generators on? Rectifiers on? Turbine RPMs high enough? All the pertinent switches in the LH/RH triangle panels on? Fuses on? Because the AP certainly works when the chopper is started up manually using a RL checklist.


Edited by msalama

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

Generators on? Rectifiers on? Turbine RPMs high enough? All the pertinent switches in the LH/RH triangle panels on? Fuses on? Because the AP certainly works when the chopper is started up manually using a RL checklist.

 

it's the default hot start. everything is on and ready to go. and as i said, i tried it again with auto start, which turns everything on automatically.

 

even so, i flew around for a bit (much tricker without pitch/roll damper) to see if anything else was weird. but nope, everything else was fine. RPM in the green, no warning lights. its very mysterious.

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

So the autostart is broken now it seems. Well, can't help you there I'm afraid, other than suggest you google "TSMO-Dash-10-TM-1-1520-Mi-17-10-Apr-07.pdf" and use the checklist provided there for startups (just ignore the SPS MAWS section since we don't have that modelled). It may feel a bit overwhelming first, but the systems are actually much _less_ complicated than first meets the eye, so why not jump in with both feet now that the opportunity presents itself I ask ;)

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

  • 1 month later...
hey all - i've written about this issue before but never got a solution. I tried it again in 2.5 and it's still happening.

 

situation: starting the elbrus rescue missions for Uh-1h, just switch the hot start version to the Mi-8. immediately the pitch/roll button won't turn on. it'll flash for a second but then stays dark. anyone else able to reproduce this?

 

edit 1: i did the auto-shutdown and then auto-start to make sure it wasn't messing with something, but even then the autopilot channel won't active... :(

Yes the same here, wont turn on. When activated it flashes green for a second and then goes out. Hard enough to fly without the pitch and roll assistance being off sigh. Have tried it in both standard and beta still the same.

Modules: KA-50, A-10C, FC3, UH-1H, MI-8MTV2, MIG-21bis, FW-190D9, F-86F, MIG-15bis, M-2000C, AJS-37 Viggen , AV-8B Night Attack V/STOL , F-5E Tiger , L-39 Albatros.

Link to comment
Share on other sites

Yes the same here, wont turn on. When activated it flashes green for a second and then goes out. Hard enough to fly without the pitch and roll assistance being off sigh. Have tried it in both standard and beta still the same.

 

glad i'm not crazy :)

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

glad i'm not crazy :)
Sometimes this game drives me crazy. Went back to standard 2.5 and I've found the roll and pitch auto pilot now work. But still broken for the beta.......for me anyway.

Modules: KA-50, A-10C, FC3, UH-1H, MI-8MTV2, MIG-21bis, FW-190D9, F-86F, MIG-15bis, M-2000C, AJS-37 Viggen , AV-8B Night Attack V/STOL , F-5E Tiger , L-39 Albatros.

Link to comment
Share on other sites

You mean when autostarting the chopper? Because a manual startup following a RL checklist most certainly works correctly in v2.5.1.

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

You mean when autostarting the chopper? Because a manual startup following a RL checklist most certainly works correctly in v2.5.1.
When i use the manual

start in the beta auto pilot does not work. When in the standard build auto pilot works after manual start. I never use auto with the mi8 it's part of the fun flicking all those switches.

Modules: KA-50, A-10C, FC3, UH-1H, MI-8MTV2, MIG-21bis, FW-190D9, F-86F, MIG-15bis, M-2000C, AJS-37 Viggen , AV-8B Night Attack V/STOL , F-5E Tiger , L-39 Albatros.

Link to comment
Share on other sites

Same here, complete manual start in 2.5.1, everything working good.

" You must think in russian.."

[sIGPIC][/sIGPIC]

 

Windows 7 Home Premium-Intel 2500K OC 4.6-SSD Samsung EVO 860- MSI GTX 1080 - 16G RAM - 1920x1080 27´

 

Hotas Rhino X-55-MFG Crosswind Rudder Pedals -Track IR 4

Link to comment
Share on other sites

I have the same issue as the OP, and it's been like that for some time. Since I don't really fly the Mi8 I don't really care. But I saw a post on this some time back and commented on it. I guess some users have the issue and some don't.

Link to comment
Share on other sites

I guess some users have the issue and some don't.

 

Maybe so, but it seems to affect autostart only. I just did a manual startup and flew a short trip and there were no problems whatsoever with any of the systems.

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

Maybe so, but it seems to affect autostart only. I just did a manual startup and flew a short trip and there were no problems whatsoever with any of the systems.

 

autostart AND hot start. not sure if they're based on the same code or not

Acer Predator Triton 700 || i7-7700HQ || 512GB SSD || 32GB RAM || GTX1080 Max-Q || FFB II and Thrustmaster TWCS Throttle || All DCS Modules

Link to comment
Share on other sites

Maybe. Or maybe it is an operator error after all. Hard to say since I can't see what y'all do there ;) But I've never seen this happen myself and I fly the Hip all the time...

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

The autopilot pitch/roll fails to work for me every now and then on the Oilfield campaign. The light will not activate and the pitch/roll is very unstable. I have also noticed that the green light sometimes blinks for a millisecond when pressing it. I have even had the AI say "autopilot on" once when trying it off and on numerous times. Exiting the mission and starting over clears the issue for that instance.

Yesterday I also had an issue with the right engine not starting. This is the first time this has happened to me. I tried shutting it off and returning the handle to the rear, then selecting crank instead of start thinking maybe I could crank it and clear any fuel out and try again. Maybe not the correct line of thought but we used to have to do that on the old Continental 9 cylinder radial engines before startup so why not try. It didn't work and I had to restart the campaign to clear that...

Anyway you are not alone in this issue.

By the way; I have heard people mention repair once or twice in passing. Is there a repair function? Maybe in the comms menu???

Cheers!

Link to comment
Share on other sites

Yah, seems the bug is for real. And it's a strange one, too. Never EVER seen it myself, and I've got like 2000hrs+ in this chopper already. Manual starts though, but still...

The DCS Mi-8MTV2. The best aviational BBW experience you could ever dream of.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...