Jump to content

Add Radio Item trigger Problem


The Jack
 Share

Recommended Posts

Good morning,

 

I am new'ish to mission building and I have a problem and was hoping one of you talented guys could help me with a multiplayer mission I am creating?

 

I have two A10 air units - Boar and Hawg, as well as radio down to two ground units - Zulu One and Zulu Two.

 

My idea is for the two A10 to receive their sortie tasking orders in game (via either text or sound) then clear specific mission areas, then once the area is clear of enemy units have them radio in to give the ground units clearance to move in to hose areas.

 

I have it half working... scoured this forum (found the answers baffling and hard to digest) and the web, as well as using Gloo Toob video tutorials.... to get where I am!

 

I am at I have one set of commands working for both aircraft not one each.

 

Any help would be very much appreciated or a link to an idiots in depth single syllable word guide would also be epic!!

 

I have attached my mission file too.

 

Thanks

UKATC Operation Lazic.miz

Link to comment
Share on other sites

Thanks for the reply...

 

My idea is this:

 

Group A, Group B, Group C and Group D

 

 

I would like:

Group A to control Group C

 

Group B to control Group D

 

I would also like to add radio commands for Group A and Group B so that they can recieve individual Mission Orders


Edited by The Jack
Link to comment
Share on other sites

The folks who have drank the kool aid will always say that (no offense Hardcard ;) ) and in some cases it is absolutely correct and the path of least resistance...but if you're not a programmer this isn't necessarily one of them. The built in GUI is extremely powerful and should be able to handle this with no issues. I'll take a peek a little later today and see if I can find the source of your woes.

Link to comment
Share on other sites

@The Jack

 

I recommend that you learn some Lua scripting, your life as a mission creator will be infinitely better.

 

I did look at this but my brain just won't compute... I am old and in need of shooting... I also do enough cock ups in the mission editor, so if I do somehow manage to script. I will probably lose my last marble trying to fathom out what has gone wrong when I cock that up...

 

 

The folks who have drank the kool aid will always say that (no offense Hardcard ;) ) and in some cases it is absolutely correct and the path of least resistance...but if you're not a programmer this isn't necessarily one of them. The built in GUI is extremely powerful and should be able to handle this with no issues. I'll take a peek a little later today and see if I can find the source of your woes.

 

Thank you :thumbup:

Link to comment
Share on other sites

That was a weird one. I noticed that upon entering Boar Flight at mission start, I received Hawg flight's radio triggers, but if I returned to spectators then re-entered Boar flight again I received the proper menus.

 

I added a slight delay between the radio commands being added and that seemed to correct the issue. Nothing you did was incorrect as far as how to populate the menus, just some kind of gremlin in the .miz. I did notice a couple minor housekeeping items, such as all radio triggers being available immediately so I removed the ability to push the armor before recieving tasking.

 

There were also a few minor issues that would prevent this from working properly in multiplayer that I corrected:

 

1) Late-activated, visible before start units will not appear to move for clients in a multiplayer session, only for the host. For clients, those units will appear to remain stationary for the entire mission. The workaround is to use GROUP AI OFF at mission start, then activate the units with GROUP AI ON.

 

2) Client aircraft in a multiplayer session cannot be detected with group-level triggers such as GROUP ALIVE or PART OF GROUP IN ZONE. Instead, you must use UNIT ALIVE/UNIT INSIDE ZONE for any MP clients.

 

3) One of the aircraft was set to "Player." All pilotable airframes should be set to "Client" for a multiplayer or multi-aircraft mission.

UKATC Operation Lazic FIXED.miz

Link to comment
Share on other sites

That was a weird one. I noticed that upon entering Boar Flight at mission start, I received Hawg flight's radio triggers, but if I returned to spectators then re-entered Boar flight again I received the proper menus.

 

I added a slight delay between the radio commands being added and that seemed to correct the issue. Nothing you did was incorrect as far as how to populate the menus, just some kind of gremlin in the .miz. I did notice a couple minor housekeeping items, such as all radio triggers being available immediately so I removed the ability to push the armor before recieving tasking.

 

There were also a few minor issues that would prevent this from working properly in multiplayer that I corrected:

 

1) Late-activated, visible before start units will not appear to move for clients in a multiplayer session, only for the host. For clients, those units will appear to remain stationary for the entire mission. The workaround is to use GROUP AI OFF at mission start, then activate the units with GROUP AI ON.

 

2) Client aircraft in a multiplayer session cannot be detected with group-level triggers such as GROUP ALIVE or PART OF GROUP IN ZONE. Instead, you must use UNIT ALIVE/UNIT INSIDE ZONE for any MP clients.

 

3) One of the aircraft was set to "Player." All pilotable airframes should be set to "Client" for a multiplayer or multi-aircraft mission.

 

Thank you feefifofum :thumbup::thumbup::thumbup:

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...