Jump to content

Unit callsign changes not reflected by the 2.8 unit map labels


Blackdog
 Share

Recommended Posts

The callsign name displayed on the new map labels don't change from the callsign that the unit had in the ME when the unit callsign changes (either pre- or post- Activation).

This is very unfortunate for anybody trying to make sense of the map (especially if they are trying to GCI) for complex missions.  Callsign 'changes' frequently happen in mission scripting where late-activated groups/units are used as templates for dynamically spawning many groups -- as a result, dynamically created units created from such templates all stuck with the callsign map label of their template. 

I've attached an very basic example .miz to demonstrate the problem.

The 3 tanker units are placed in ME to late activate with "Arco" callsigns.

At 5 seconds setCommand is used to change their callsigns to "Texaco" just before activating them.  You can click through the units and see that even though their callsign has changed to "Texaco-X-X" the map label still shows "ArcoXX".

At 15 seconds setCommand changes them to "Shell" callsigns, and as you click through the 3 units you can see they have "Shell" callsigns but the original label has still not changed.

The labels don't update even if you start in, for example, a jet slot then switch to an observer role after the callsign change has occurred.

image.png

TankerSetCallsignTest.miz


Edited by Blackdog
leading 'null' in text body for some reason.
  • Like 1
Link to comment
Share on other sites

16 hours ago, Flappie said:

This was reported earlier:

 


Hi Flappie, this is clearly distinct issue from the other bug, and is not related other than they both happen to involve a setCommand callsign change.  

The other issue is multiplayer only, existed before 2.8, seems to be client-sync related (different clients can 'see' different things), and impacts the actual function of the unit (in that the callsign change doesn't happen) for the client experiencing it.

This issue is specifically to do with the new 2.8 F10 labels, happens in both single player and multiplayer, and isn't related to the actual function of the units and their callsigns.  It is a much more straightforward issue that other one:   The F10 map callsign labels don't change (single player or in multiplayer).  It is unrelated to the function of the units themselves.

To put it a different way:  The other bug is a problem involving the actual callsign change, this bug is specifically an issue involving the new 2.8 F10 map unit labels.

I was the one that provided the .miz and details to reproduce the other bug, so I'm very familiar with both 🙂 

If I can elaborate further please let me know.

-Blackdog

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...