Jump to content

[CLOSED]Consistent crash in same mission


brunodk
 Share

Recommended Posts

Hi. I've created a mission which I have attached. When I try and run the mission, the game crashes after about 11 min (in-game time), and so does the launcher (launcher.exe) that starts up after I've closed dcs.exe due to the crash.

 

I've done it several times. Always the same behaviour.

 

First crash (dcs.exe):

Faulting application name: dcs.exe, version: 1.2.5.15865, time stamp: 0x51f13011

Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000

Exception code: 0xc0000005

Fault offset: 0x0000000119930522

Faulting process id: 0x11a0

Faulting application start time: 0x01ce8d3d5bc7f0c6

Faulting application path: C:\Games\DCS World\bin\dcs.exe

Faulting module path: unknown

Report Id: c2a89e78-f930-11e2-bed1-c86000dd96b0

Faulting package full name:

Faulting package-relative application ID:

 

 

Second crash (launcher.exe):

Faulting application name: Launcher.exe_DCS, version: 1.2.5.15865, time stamp: 0x51ee7669

Faulting module name: Effects.dll, version: 1.2.5.15865, time stamp: 0x51ee76f3

Exception code: 0xc0000005

Fault offset: 0x0000000000034a44

Faulting process id: 0x1050

Faulting application start time: 0x01ce8d3d5b0bf221

Faulting application path: C:\Games\DCS World\bin\Launcher.exe

Faulting module path: C:\Games\DCS World\bin\Effects.dll

Report Id: cf895a20-f930-11e2-bed1-c86000dd96b0

Faulting package full name:

Faulting package-relative application ID:

COMPLEX.miz

logs.zip

i7 3770k 3.5 Ghz (OC 4.3 Ghz), 16 GB Ram, Radeon 7970, Win8 64-bit, CH Products Fighterstick + Pro Pedals + Pro Trottle, TrackIR 5

Link to comment
Share on other sites

Just ran the mission, in a bit of unusual way though.

Launched the mission, picked my slot (KA50 enfield 1-2)

Unpaused the game.

 

And that's all i did, just left my computer alone after that.

Mission was still running when i came back after 13 minutes.

 

So this probably means the crash only happens after user input.

ill go and have a look in the mission editor for any triggers etc anyway though.

 

 

***EDIT***\

Ran for a second time after looking at the triggers and seeing the radio menu options.

This time i picked the lead A10C and started it using the cheat start up.

Once it was started up i used the radio menu.

When i used the option "F1, Request Task" the column Q1 stopped where it was.

(not sure why, triggers don't seem to be set up this way)

When i then used the option "F1, Request Sitrep" nothing happened.

Waited till about 13 mins orso had passed and again no crash.

 

 

***EDIT***

Made a small modification to the mission, being that i changed the column Q1 escort to one vehicle (unarmed HMMV)

And set the speed to max (72km/h) this way it would reach WP1 sooner where it should hold according the advanced wp menu

 

Ran the mission, again in the A10C slot, again started whit cheat startup

Waited for the Q1 Escort to stop at WP1, it did, so far nothing strange

used radio menu again, Request Task, Q1 Escort resumed driving

After a little while i used radio menu again, request sitrep, nothing happend.

Waited for Q1 escort to reach the town, where it would be killed by the ambush.

HMMV got killed by rpg, no crash

used radio menu again to request a task, and nothing happened.

 

So, how are you flying this mission?

What are you doing / have you done when it crashes?

Is the first enemy infantry group alive when it crashes? Are some of them dead?

Or is the whole group dead?


Edited by 159th_Falcon

[sIGPIC][/sIGPIC]

The keeper of all mathematical knowledge and the oracle of flight modeling.:)
Link to comment
Share on other sites

I've tried to run my mission again, and well, now it doesn't crash - very weird!

 

When I made the mission and tried it out, it crashed every single time after about 11 min in-game, but now... nothing.

 

The way I made it crash was simply to pick an aircraft (ka 50 or A-10C) and wait with or without LCtrl+Z for time speed.

 

Why is doesn't happen now is beyond me.

 

 

*** EDIT ***

 

I'm able to make it crash again.

 

What I did:

1. Deleted the DCS folder in Temp (C:\Users\Bruno\AppData\Local\Temp\DCS).

2. Ran the mission from the ME, selected A-10C Enfield11, switched on the battery, and watched the A-10C clock reach approximately 12:11 (using time speedup) where dcs.exe crashes followed by launcher.exe.

 

How I fixed it:

1. The Q1 Escort group has two "Transmit Message" triggers. I removed them, and now it doesn't crash.

 

 

NOTE: I've seen the game become unstable before when clearing the Temp folder, but I can't be sure.


Edited by brunodk

i7 3770k 3.5 Ghz (OC 4.3 Ghz), 16 GB Ram, Radeon 7970, Win8 64-bit, CH Products Fighterstick + Pro Pedals + Pro Trottle, TrackIR 5

Link to comment
Share on other sites

Can you try re-adding the Transmit Nessage triggers in now and see if it crashes, or if it was some inconstancy from an older version.

 

I'll ask about the temp folders...

 

I tried to re-add the triggers with no effect, it still crashes.

i7 3770k 3.5 Ghz (OC 4.3 Ghz), 16 GB Ram, Radeon 7970, Win8 64-bit, CH Products Fighterstick + Pro Pedals + Pro Trottle, TrackIR 5

Link to comment
Share on other sites

  • ED Team

Ok, so with those triggers you get the crashes, gonna try and play through your mission you posted earlier.

 

 

I tried the mission with no crashes, I will try and make a mission with a bunch of those triggers and see what happens... tomorrow yawn :)


Edited by NineLine

64Sig.png
Forum RulesMy YouTube • My Discord - NineLine#0440• **How to Report a Bug**

1146563203_makefg(6).png.82dab0a01be3a361522f3fff75916ba4.png  80141746_makefg(1).png.6fa028f2fe35222644e87c786da1fabb.png  28661714_makefg(2).png.b3816386a8f83b0cceab6cb43ae2477e.png  389390805_makefg(3).png.bca83a238dd2aaf235ea3ce2873b55bc.png  216757889_makefg(4).png.35cb826069cdae5c1a164a94deaff377.png  1359338181_makefg(5).png.e6135dea01fa097e5d841ee5fb3c2dc5.png

Link to comment
Share on other sites

Cause narrowed down, but unable to reproduce on our tester version. Hopefully that means it will be in the next patch but that is currently unknown.

The right man in the wrong place makes all the difference in the world.

Current Projects: Scripting Wiki, Something...

Useful Links: Mission Scripting Tools MIST-(GitHub) MIST-(Thread), SLMOD, IADScript, Mission Editing Wiki!, Mission Building Forum

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...