Jump to content

ARC-5 frequencies


Recommended Posts



I have recently installed the MIG-15 module and one thing I can really not get to work is the ARC-5 radio navigation system.


When I turn the switch to modify the frequencies range, the switch rotates to every three positions but the indicator remains blocked only on the first frequencies range (see pics).


Am I missing a point to enable the two other frequencies range ?


Thanks for help




Link to comment
Share on other sites

Hi Britchot,


Yes indeed the correct position is on Compass. But I tried all positions as it did not work (even shortly earlier today).


But I found something useful I think. After testing the system on an airborne start, everything worked well. So I pondered about what might have gone wrong on the ground.


And the most plausible answer is, I think, electrical power. I have noticed that if you do not respect the procedure with electrical power, you may ruin the battery, and indeed, in that situation I was unable to change the frequencies, again.


But if you do things in the correct order, and use properly the gound power supply, everything works...


So I think this thread can be set as SOLVED, yet who knows, it might help other people having the same problem as me.


And thanks for answering :thumbup:

Link to comment
Share on other sites

That being said, If I recall correctly rotating the switch in the real thing (sitting in one in the museum), the indicator was a strictly mechanical device connected to the switch, so battery power, or ground power, or Girl Power, or Power Rangers or whatever power should be irrelevant :D.


Looks like a bug / incorrect implementation then, but not serious issue.

Edited by Art-J

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...