Jump to content

Uncontrolled/late activation of AI aircraft causes some sort of game freeze problem


sirrah
 Share

Recommended Posts

I was altering the default Hornet cold and dark PG mission (added some aircraft, changed weather and some statics) when I stumbled on an issue.

 

I added a flight of 2 cold and dark Tomcats. My idea was, to be able to take off at about the same time they would. I forgot however that all AI aircraft somehow have instant INS alignment and it takes 'em about 20 secs to do a full cold and dark startup... At that time I have my APU running...

 

Anyways, then I tried setting the Tomcats to "uncontrolled" and set the starting time to +10 seconds, to test it. After 10 secs in the mission my screen sort of freezes, but I think the game continues. I can also still press escape and quit the mission normally..

 

Also tried with "late activation" tagged. Same results.

 

 

I added the miz file

SUPERCARRIER-HORNET-COLD START Edited.miz

System specs:

 

i7-8700K @stock speed - GTX 1080TI @ stock speed - AsRock Extreme4 Z370 - 32GB DDR4 @3GHz- 500GB SSD - 2TB nvme - 650W PSU

HP Reverb G1 v2 - Saitek Pro pedals - TM Warthog HOTAS - TM F/A-18 Grip - TM Cougar HOTAS (NN-Dan mod) & (throttle standalone mod) - VIRPIL VPC Rotor TCS Plus with ALPHA-L grip - Pointctrl & aux banks <-- must have for VR users!! - Andre's SimShaker Jetpad - Fully adjustable DIY playseat - VA+VAICOM

 

~ That nuke might not have been the best of ideas, Sir... the enemy is furious ~ GUMMBAH

Link to comment
Share on other sites

I was altering the default Hornet cold and dark PG mission (added some aircraft, changed weather and some statics) when I stumbled on an issue.

 

 

 

I added a flight of 2 cold and dark Tomcats. My idea was, to be able to take off at about the same time they would. I forgot however that all AI aircraft somehow have instant INS alignment and it takes 'em about 20 secs to do a full cold and dark startup... At that time I have my APU running...

 

 

 

Anyways, then I tried setting the Tomcats to "uncontrolled" and set the starting time to +10 seconds, to test it. After 10 secs in the mission my screen sort of freezes, but I think the game continues. I can also still press escape and quit the mission normally..

 

 

 

Also tried with "late activation" tagged. Same results.

 

 

 

 

 

I added the miz file

You have blocked all available parkingspots for the Tomcats, it seems. Next you spawn the Tomcat 10 seconds late, but uncontrolled. They need a triggered action to "Start", so they take off later.

In addition, the performance hits through the amount of high polygon F/A-18C and all the other stuff is considerable. There is a manual for the Supercarrier in C:/DCS World/Mods/tech/Supercarrier/Docs

At the end there are mission designer tips.

Shagrat

 

- Flying Sims since 1984 -:pilotfly:

Win 10 | i5 10600K@4.1GHz | 32GB | GeForce RTX 2080S - Acer XB280HK 28" 4k | TrackIR5 | Simshaker & Jetseat | VIRPIL CM 50 Stick & Throttle | MFG Crosswind Rudder Pedals | TM Cougar MFDs | a hand made UFC | AHCP | 2x Elgato StreamDeck (Buttons galore)

Link to comment
Share on other sites

Thanks for taking a look

 

You say I blocked all parking spots, however if I let the Tomcats start without time delay, they start without any issues behind cat 1 and 2.

 

About the spawn trigger.. you're right.. forgot about that :doh:

 

Oh and concerning performance, it all runs smooth (35fps) until the Tomcats try to spawn. Then the game still runs but I get this really strange extreme camera stutter (I'll try and make a video of it as soon as I get the chance). Maybe it's happening because I forgot about a proper spawn trigger.

System specs:

 

i7-8700K @stock speed - GTX 1080TI @ stock speed - AsRock Extreme4 Z370 - 32GB DDR4 @3GHz- 500GB SSD - 2TB nvme - 650W PSU

HP Reverb G1 v2 - Saitek Pro pedals - TM Warthog HOTAS - TM F/A-18 Grip - TM Cougar HOTAS (NN-Dan mod) & (throttle standalone mod) - VIRPIL VPC Rotor TCS Plus with ALPHA-L grip - Pointctrl & aux banks <-- must have for VR users!! - Andre's SimShaker Jetpad - Fully adjustable DIY playseat - VA+VAICOM

 

~ That nuke might not have been the best of ideas, Sir... the enemy is furious ~ GUMMBAH

Link to comment
Share on other sites

Thanks for taking a look

 

 

 

You say I blocked all parking spots, however if I let the Tomcats start without time delay, they start without any issues behind cat 1 and 2.

 

 

 

According to the manual, aircraft spawn on defined spawn points. 1,2,3,4 being the Six-pack and only used on mission start. Aircraft with Start from Runway spawn ON the catapults. All Start from Parking will fill up the spawn points in order of their creation in the mission editor or on their spawn time. Now you completely blocked all spawn points with player aircraft or statics, including the six-pack, all elevators (spawn points 5,6,7,8,9,10) and the patio, point and corral, with no spawn points available other than the catapults, which require Start from Runway and will spawn the aircraft on the CAT as soon as a CAT is available.

I also recommend to start with only Hornets, as the Tomcats are WIP and tend to cause issues as AI at the moment. Build the Deck step by step, plane by plane until you are familiar with the spawn points, taxi routes and fill remaining spawn points one by one. May be delaying certain AI spawns and have them occupy slots as "uncontrolled" to force a specific spawn point for the player aircraft, before adding statics. Statics on the Six-pack is asking for trouble, as they block the AI routes to the CATs 1 + 2 and the Taxi routes to parking, so landing aircraft will need to despawn on the runway instead of taxiing to a parking spot/elevator and you miss the nice elevator animation with aircraft going into the hangar deck to despawn.

Shagrat

 

- Flying Sims since 1984 -:pilotfly:

Win 10 | i5 10600K@4.1GHz | 32GB | GeForce RTX 2080S - Acer XB280HK 28" 4k | TrackIR5 | Simshaker & Jetseat | VIRPIL CM 50 Stick & Throttle | MFG Crosswind Rudder Pedals | TM Cougar MFDs | a hand made UFC | AHCP | 2x Elgato StreamDeck (Buttons galore)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...