Jump to content

Keyword training


SkipperSMG
 Share

Recommended Posts

After addition of the Realistic ATC expansion, my speech recognition suffers significant problems. Basically, it does not understand s***.

 

I tried to train by using the VAICOM build-in training mode, but something is not right there. VA log does not show inputs at all. When i start the voice recognition first and then sellect the keyword to be trained afterwards, then its doing something but input is recognized as dictation.

 

I am a little bit stuck because VA does not recognize my calls although i am quite confident with my pronunciation as a non-native speaker and i see no way to train it. Any ideas what i can do?

 

 

Thanks in advance

i5-2400 | 16GB Corsair XMS3 | MSI GTX 970 4GB | 500GB Samsung 850 Evo | TrackIR 5 | TM Warthog | Saitek Rudder Pedals | Windows 10 64 bit

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

check that you have the right mic selected. to be safe, maybe unplug any other mics/headsets

 

check that the sliders on the EX tab are set to match your installation

 

As DCS has also recently been updated, make sure that you have done the usual steps: delete export.lua, set custom path etc

Link to comment
Share on other sites

check that you have the right mic selected. to be safe, maybe unplug any other mics/headsets

 

check that the sliders on the EX tab are set to match your installation

 

As DCS has also recently been updated, make sure that you have done the usual steps: delete export.lua, set custom path etc

 

 

checked. VA and VAICOM work properly as far as concerning DCS. Speech recognition just barely understands what im saying and i am looking for a way to train :( i might do something wrong but i have the feeling the keyword training is not working as intended.

i5-2400 | 16GB Corsair XMS3 | MSI GTX 970 4GB | 500GB Samsung 850 Evo | TrackIR 5 | TM Warthog | Saitek Rudder Pedals | Windows 10 64 bit

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

checked. VA and VAICOM work properly as far as concerning DCS. Speech recognition just barely understands what im saying and i am looking for a way to train :( i might do something wrong but i have the feeling the keyword training is not working as intended.

 

 

Just checking this is what you are doing to see how to help:

 

 

1. Opening the VAICOM config window

2. Selecting the Editor tab

3. Clicking on the microphone so it gets a yellow border

4. When the Microsoft speech recognition window appears making sure the Microphone button is coloured blue and it says listening (if it says Sleeping click on the microphone button and (Windows speech and not VAICOM)

5. Speaking the VAICOM phrase(s) you want to train

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

Just checking this is what you are doing to see how to help:

 

1. Opening the VAICOM config window

2. Selecting the Editor tab

3. Clicking on the microphone so it gets a yellow border

4. When the Microsoft speech recognition window appears making sure the Microphone button is coloured blue and it says listening (if it says Sleeping click on the microphone button and (Windows speech and not VAICOM)

5. Speaking the VAICOM phrase(s) you want to train

 

 

thats what i do. Some of the keywords get recognized correctly as shown in the speech recognition window. But most of the phrases turn out to be gibberish. Also, there is no indication that its actually training as far as i can see but i dont know it it is like that. Recording samples to the keywords in the dictionary also has absolutely no effect. Im a little lost here :helpsmilie:

i5-2400 | 16GB Corsair XMS3 | MSI GTX 970 4GB | 500GB Samsung 850 Evo | TrackIR 5 | TM Warthog | Saitek Rudder Pedals | Windows 10 64 bit

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

If single keywords are recognised OK and phrases are not it might be worth trying to slow down your speech a little bit and possibly leave small pauses between some of the words.

 

 

From your first post, was this working fine for you before the update?

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

If single keywords are recognised OK and phrases are not it might be worth trying to slow down your speech a little bit and possibly leave small pauses between some of the words.

 

 

From your first post, was this working fine for you before the update?

 

 

This might be a little misleading, in fact it does not matter if a single word or a phrase made of multiple words. It was. But after indrocution of the realistic ATC commands it got worse. I thought i could get around be doing some training but it does not seem to train.

 

 

I just add phrases to the speech recognition dictionary. It seems to work pretty good.

 

 

I did. Not difference whatsoever.

i5-2400 | 16GB Corsair XMS3 | MSI GTX 970 4GB | 500GB Samsung 850 Evo | TrackIR 5 | TM Warthog | Saitek Rudder Pedals | Windows 10 64 bit

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

This might be a little misleading, in fact it does not matter if a single word or a phrase made of multiple words. It was. But after indrocution of the realistic ATC commands it got worse. I thought i could get around be doing some training but it does not seem to train.

 

 

 

 

 

I did. Not difference whatsoever.

Have you tried switching to the VSPX voice engine rather than Microsoft's engine (this worked for someone else yesterday).

 

Another trick someone else pointed out was in the Windows speech options there is an option to recognise non-native accents.

 

Sent from my SM-T835 using Tapatalk

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

Have you tried switching to the VSPX voice engine rather than Microsoft's engine (this worked for someone else yesterday).

 

Another trick someone else pointed out was in the Windows speech options there is an option to recognise non-native accents.

 

Sent from my SM-T835 using Tapatalk

 

 

 

Yes i did, following the instructions. After 20 min of testing i switched back because i saw no difference.

i5-2400 | 16GB Corsair XMS3 | MSI GTX 970 4GB | 500GB Samsung 850 Evo | TrackIR 5 | TM Warthog | Saitek Rudder Pedals | Windows 10 64 bit

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Another trick someone else pointed out was in the Windows speech options there is an option to recognise non-native accents.

 

Sent from my SM-T835 using Tapatalk

VA does have an issue with my Scouse accent, it thinks ATC is JTAC and a long list of other words not recognised. Where is this option in speech recognition? Latest Win10 :helpsmilie:

Link to comment
Share on other sites

VA does have an issue with my Scouse accent, it thinks ATC is JTAC and a long list of other words not recognised. Where is this option in speech recognition? Latest Win10 :helpsmilie:
In windows search, type in speech settings and there should be a checkbox under speech language

 

Sent from my SM-T835 using Tapatalk

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

I have just checked mine and it is there (also latest build for Windows 10 home). Alternative way is to go into Settings > Time & Language > Speech


Edited by hornblower793

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

Is there any way to tell the speech engine that it got its guess right? I was doing some keyword training and the strike rate was about 50%. Looks like I will have to spend a lot of time training but it will be worth it in the end.

Link to comment
Share on other sites

  • 5 months later...

VA does have an issue with my Scouse accent, it thinks ATC is JTAC and a long list of other words not recognised. Where is this option in speech recognition? Latest Win10 :helpsmilie:

 

Definately doesn't like us Northerners! I left Newcastle 25 years ago but I guess I still have a Geordie twang. I've been repeatedly saying "Kobuleti" into the mic for the last hour and the closest I've got is a 35% confidence level. At one point it thought I'd said "ATC" which I'd actually settle for at this point ! And I'm using a decent powered studio mic through a Focusrite interface, all VA and VIACOM settings as per the setup guide in the manual.

 

 

 

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

My DCS Apps:    Radio KAOS for DCS      KB Quick - Quick and Easy Kneeboards

Link to comment
Share on other sites

 

Definately doesn't like us Northerners! I left Newcastle 25 years ago but I guess I still have a Geordie twang. I've been repeatedly saying "Kobuleti" into the mic for the last hour and the closest I've got is a 35% confidence level. At one point it thought I'd said "ATC" which I'd actually settle for at this point ! And I'm using a decent powered studio mic through a Focusrite interface, all VA and VIACOM settings as per the setup guide in the manual.

 

 

 

..Just used Windows Speech Recognition to add "Kobuleti" to it's dictionary, and added my spoken pronunciation. Now I'm getting a 100% confidence level ! Many thanks Greyman for the suggestion above.

 

I guess I just need to spend a few days teaching Windows to "Larn Yasel' Geordie" and I'll be golden ;)

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

My DCS Apps:    Radio KAOS for DCS      KB Quick - Quick and Easy Kneeboards

Link to comment
Share on other sites

I noticed SkipperSMG only listed the first part of keyword training

 

1. Opening the VAICOM config window
2. Selecting the Editor tab
3. Clicking on the microphone so it gets a yellow border
4. When the Microsoft speech recognition window appears making sure the Microphone button is coloured blue and it says listening (if it says Sleeping click on the microphone button and (Windows speech and not VAICOM)
5. Speaking the VAICOM phrase(s) you want to train

 

But then the next steps confuse me as well.

6) hit the 'finish' button

7) read the dialog that pops up

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264157_1606419634937_64","title":"va.png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

8) click on the 'pencil' icon in VA to edit the VAICOM PRO for DCS World profile. This dialog below is the one that pops up.

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264158_1606419702721_635","title":"VAICOMprofile edit dialog.png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

Now this is where I get lost.

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

It says to 'double click the 'AI Communications' command and clear all the keywords!

In the pic above, if I double click the cell with 'AI communications' in the highlighted blue row, I get this dialog

 

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264160_1606419861717_55","title":"VAICOM AIComm desc .png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

It wants me to delete all the words highlighted in the blue row?! That's the entire dictionary.

When I do that and then ctrl-C , it seems to paste the entire dictionary back in. Did I actually do anything??

1989871446_VAHollywood.thumb.png.a3979074838eedf5eaacc7f23c6fedd3.png

4930K @ 4.5, 32g ram, TitanPascal

Link to comment
Share on other sites

That's correct, yes. WHENEVER you press the "Finish" button" the entire set of AI Communications keywords defined in VIACOM is copied to your clipboard, so you must clear the entire AI Communications keywords list in VA before pasting in the copied list.

 

So this replaces the entire AI Communications list in VA, adding any new keywords that might have been added in VIACOM (either manually yourself or through the addition of a new plugin feature like the Kneeboard or AIRIO).

 

 

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

My DCS Apps:    Radio KAOS for DCS      KB Quick - Quick and Easy Kneeboards

Link to comment
Share on other sites

That's correct, yes. WHENEVER you press the "Finish" button" the entire set of AI Communications keywords defined in VIACOM is copied to your clipboard, so you must clear the entire AI Communications keywords list in VA before pasting in the copied list.

 

So this replaces the entire AI Communications list in VA, adding any new keywords that might have been added in VIACOM (either manually yourself or through the addition of a new plugin feature like the Kneeboard or AIRIO).

RYZEN 5900X | 32GB | ASUS Strix RTX3090 | 500GB NVMe OS 1000GB NVMe DCS | Warthog HOTAS | HP Reverb G2 | VA & ViacomPRO

My DCS Apps:    Radio KAOS for DCS      KB Quick - Quick and Easy Kneeboards

Link to comment
Share on other sites

skypickle, you are confusing the training process with the Finish process. They are independent. You can train without doing a Finish or vice versa. You need to do the Finish process whenever new keywords are added to the dictionary. Do follow the directions in the Finish instructions exactly. It may appear that you are deleting the entire keyword list and then re-adding it. What you are doing is deleting all keywords from the VA profile and then adding back in all keywords that are in the VA keyword database. Those may seem the same, but they are not the same if the Finish button is hilighted.

 

 

I noticed SkipperSMG only listed the first part of keyword training

 

1. Opening the VAICOM config window
2. Selecting the Editor tab
3. Clicking on the microphone so it gets a yellow border
4. When the Microsoft speech recognition window appears making sure the Microphone button is coloured blue and it says listening (if it says Sleeping click on the microphone button and (Windows speech and not VAICOM)
5. Speaking the VAICOM phrase(s) you want to train

 

But then the next steps confuse me as well.

6) hit the 'finish' button

7) read the dialog that pops up

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264157_1606419634937_64","title":"va.png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

8) click on the 'pencil' icon in VA to edit the VAICOM PRO for DCS World profile. This dialog below is the one that pops up.

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264158_1606419702721_635","title":"VAICOMprofile edit dialog.png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

Now this is where I get lost.

wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

It says to 'double click the 'AI Communications' command and clear all the keywords!

In the pic above, if I double click the cell with 'AI communications' in the highlighted blue row, I get this dialog

 

[ATTACH=JSON]{"data-align":"none","data-size":"full","data-tempid":"temp_264160_1606419861717_55","title":"VAICOM AIComm desc .png"}[/ATTACH]wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

It wants me to delete all the words highlighted in the blue row?! That's the entire dictionary.

When I do that and then ctrl-C , it seems to paste the entire dictionary back in. Did I actually do anything??

 

 

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

well, i did a lot of training but then did not click the finish button. It said I still had 416 unresolved aliases. So I guess to make the training 'stick' I have to 'Finish', even if I did not add any new words.

I am thinking about adding words to control the OSB buttons in the A10.

4930K @ 4.5, 32g ram, TitanPascal

Link to comment
Share on other sites

well, i did a lot of training but then did not click the finish button. It said I still had 416 unresolved aliases. So I guess to make the training 'stick' I have to 'Finish', even if I did not add any new words.

I am thinking about adding words to control the OSB buttons in the A10.

 

No. The training "sticks" whether you do the Finish step or not. Training helps Voice Attack recognize those phrases. But it won't pass them to VAICOM unless you do the Finish step.

 

 

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...