Jump to content

Conflicting control profiles between the CW and non-CW variant.

Recommended Posts

There are two variants in the game, but you cant change the controls separately in-game, since only one shows up in the controls menu.

But there are two folders in saved games. SpitfireLFMkIX and SpitfireLFMkIXCW


And here comes the problem, I NEVER EVER fly the CW, but the game sometimes chooses to use CW controls (from saved games).

And sometimes it chooses to use the non-CW controls(from saved games).


And it creates even more problems when you try to change something in the controls, sometimes it saves to the CW, sometimes it saves to normal variant.


I'm not really sure whats happening here, is this a bug or an overlooked problem?

I remember this happening a year ago, and its still happening now.

What control folder it really uses or it uses both?

Why my normal spitfire uses CW controls sometimes???

Link to comment
Share on other sites


I came across the same problem and have this solution to offer - thanks to others for suggesting this.


If you try (maybe you have already) the "training" tutorial, you end up with three Spitfire folders.

On a personal note, I find this state of affairs amateurish and very, very trying, to say the least as, as you have found to your "delight", different config files come into play in different situations...   ...but, I digress.


The idea is to have just one Saved Games. Spitfirexxx folder which will be your reference folder for all Spitfres.




To have the same Config Input in my two Spit folders, I Copy the Joystick, Keyboard, Mouse and Trackir folders from my reference  SpitfireLFMkIX and Paste and Replace the same in the SpitfireLFMkIXCW folder.


In game, all my Spits now have the same config layout.

I still do not understand the difference between the "Easy" and the "Sim" Spitfires and, frankly, don't even want to know.

I just make sure that I am using the "Sim" Spit when I play and when I modify inputs.

Modified Inputs are to be found in the .LUA files which are in the Saved Games. Spitfirexxx folder(s).

The .LUA files are date and time-stamped when they are modified.

Great detective game included with this sim...


I use a Hotas and, of all the 450+ (good grief) possible keyboard shortcuts available, I just use 5 or 6 of them as, in flight, I don't have a regiment of octopuses sitting behind me.


I hope this is useful to you.


Link to comment
Share on other sites

Thanks for the tip, @Old Chap!

I've stumbled upon this as well. It really looks like a bug - both versions apparently were meant to be separate - they have separate folders, both... IIRC both need separate export scripts to the DSC Stream Deck plugin (as two separate Spits), but in DCS GUI, in that drop-down (in control assignments window), you can only select one Spit. I also had the impression that my controls got mixed up somehow, i.e. changes I made while flying CW were "invisible" when I jumped into the elliptical wing version or vice versa. Something's wrong with it.

Edited by scoobie

i7-8700K 32GB 2060(6GB) 27"@1080p TM Hawg HOTAS TPR TIR5 SD-XL button/pot box

Link to comment
Share on other sites

Toda I flew one mission in a CW to play with it, it's not what I usually pick. For my second mission I picked the standard Mk IX and found that basically, I had no controls! I tried loading the saved file but no luck. I loaded my backup file, which is in a completely different area in my HD and again nothing. Rebooted and still no joy so I spent an hour rebuilding my original Mk IX file, saving and backing it up! Big pain, no more CW for me.

Link to comment
Share on other sites

As mentioned above, just make sure you've got two folders in Saved Games / Config / Input, one for CW variant and one for non-CW, and both have exactly the same content (copy files manually when you've done any binding changes). You shouldn't have any problems with disappearing controls afterwards.


Same solution works for similar problem with -15 and -30 Mustang.

Edited by Art-J

i7 9700K @ stock speed, single GTX1070, 32 gigs of RAM, TH Warthog, MFG Crosswind, Win10.

Link to comment
Share on other sites

  • 2 months later...

This works on the mustang too, but if I open the control menus from the main menu BEFORE I enter any game then my controls load properly, but if I enter a game without opening the control menu first, then my controls don't load and I have to restart the game and remember to open the control menu first. Don't ask me why it works, but it does. 

Link to comment
Share on other sites


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...