Jump to content

Saitek X52 - Stick sort of stuck in game


Recommended Posts

Sorry, I couldn't think of a better title. Basically I have an X52 Pro joystick, when I move my joystick around, the helicopter sort of responds but then pushes the stick back to neutral.


It's like I've got something constantly trying to hold the helicopter stick dead centre but I don't know how. I've not changed any settings in game and I've tried with a cold helicopter with nothing switched on but it still snaps back thinking maybe it was some kind of autopilot that I had turned on by accident but having all the power off would suggest not.


My friend was playing around with my joystick, just pressing buttons and stuff like the numpty he is so I thought maybe he had done something but I checked the joystick out in other games and it works fine there so I don't think it's anything he's pressed by accident. It's just confined to Black Shark.


I'm wondering if someone can help me, maybe it's something I've hit in game with a keyboard shortcut but I can't think of anything I've pressed that I don't normally. I tried loading and clearing a profile, I do have that 'Saitek Rullez' thing on my MFD and my A button turns orange but before yesterday it didn't really make a difference.


If anyone could help, I'd be grateful. Oh and also, that image verifcation system is annoying

Link to comment
Share on other sites

  • ED Team

First of all - go to Options - Controls, choose "Axis Commands" from drop-down list and make new assignment to collective (by default, there is "JOY_SLIDER1" for X52). Assign your collective as JOY_Z.


Note. Check also "SIMULATION" mode or "GAME" mode in GAMEPLAY tab: for simulation you have to use "Ka-50 Real" in CONTROLS tab, for GAME mode - "Ka-50 Game".


If you not familiary with Saitek SST software - don't use it for first time, make necesssary buttons assignment direct in OPTIONS tab in game.


RTFM of course.


Added. Please, read also this post from Acedy: http://forums.eagle.ru/showpost.php?p=593189&postcount=5 !

Edited by USSR_Rik

Men may keep a sort of level of good, but no man has ever been able to keep on one level of evil. That road goes down and down.  
Можно держаться на одном уровне добра, но никому и никогда не удавалось удержаться на одном уровне зла. Эта дорога ведёт вниз и вниз.

G.K. Chesterton

DCS World 2.5: Часто задаваемые вопросы

Link to comment
Share on other sites

what image verification system?


the problem is related to the "saitek rulez" message, there is a problem with the X-52 Pro. a friend of mine had the same issue, i think you have to start black shark, alt-tab to the desktop and open up the window with all the running services... i think you understand german (by the name of you), so: rechtsklick auf Arbeitsplatz, VERWALTEN. dort unter DIENSTE UND ANWENDUNGEN die DIENSTE anwählen, dann steht rechts eine lange liste. darin sollte irgendwas mit Sai... stehen. (SaiOut oder so). diesen dienst deaktivieren(stoppen) und neu starten, dann sollte es gehen.


otherwise, just search the forum for "saitek rulez" and you will find a english description how to handle this problem...


grüsse aus der schweiz,


Democracy is choice, not freedom...

Link to comment
Share on other sites

Are you using the trim at all?


Here's the thread on the RULLEZ SAITEK thing:





System Specs


Intel I7-3930K, Asrock EXTREME9, EVGA TITAN, Mushkin Chronos SSD, 16GB G.SKILL Ripjaws Z series 2133, TM Warthog and MFD's, Saitek Proflight Combat pedals, TrackIR 5 + TrackClip PRO, Windows 7 x64, 3-Asus VS2248H-P monitors, Thermaltake Level 10 GT, Obutto cockpit


Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...