Jump to content

Auntystatic

ED Closed Beta Testers Team
  • Posts

    225
  • Joined

  • Last visited

About Auntystatic

  • Birthday 03/10/1963

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. you can add the "Grim Reapers Stoneburner Training server" to your list, with the help of Deadlyfishes, Pikey, Ciribob and Grimes we run a great training area where new players can come on and make as many mistakes as they want without any shaming as we have all been there, it would be great to make more dynamic random missions for people to fly as they get more experienced, the server certainly wouldn't be where it is today without Moose and CTLD so more functionality would be very welcome
  2. I see ships just fine, and others I know see them too
  3. I'm currently building the engine panel inspired by Teacyphers original work and thought I would share my work so far, I have all 6 displays and the 2 comm displays working off a single arduino nano with a tca9648a multiplexor board, this is built on prototype board but stripboard or dedicated pcb would be better, I need to find a font with arrows and put that in for the stab display and the overall font is not quite right but does look ok, I'll post updates as I go but thought I would share. harrier_engine_displays_experiment2.ino I'm also trying this option a 3.5" tft on an uno, which is the same size but I'm having difficulties with the code refreshing the display and I'm a noob with arduino
  4. this works really well too https://forums.eagle.ru/topic/97434-an-arduino-usb-hid-controller-composite-usb-controller/
  5. this link should be what you are looking for pinout diagram for uno to 3.2" ssd1322
  6. this is my working code, I've not used the due so you will have to find the mosi and sck pins from the due pinout chart, hope it helps you, all I need to do now is find an F-16 font that works //F-16 DED for DCS BIOS using 256x64 ER-OLED032-1G from BuyDisplay.com #define DCSBIOS_IRQ_SERIAL #include "DcsBios.h" #include <Arduino.h> #include <U8g2lib.h> #include <SPI.h> U8G2_SSD1322_NHD_256X64_1_4W_HW_SPI u8g2(U8G2_R0, /* cs=*/ 10, /* dc=*/ 9, /* reset=*/ 8); // Enable U8G2_16BIT in u8g2.h //U8G2_SSD1322_NHD_256X64_1_4W_HW_SPI u8g2(U8G2_R0, /* cs=*/ 5, /* dc=*/ 3, /* reset=*/ 4); char* line1; char* line2; char* line3; char* line4; char* line5; void onDedLine1Change(char* newValue) { line1 = (newValue); } DcsBios::StringBuffer<25> dedLine1Buffer(0x44fc, onDedLine1Change); void onDedLine2Change(char* newValue) { line2 = (newValue); } DcsBios::StringBuffer<25> dedLine2Buffer(0x4516, onDedLine2Change); void onDedLine3Change(char* newValue) { line3 = (newValue); } DcsBios::StringBuffer<25> dedLine3Buffer(0x4530, onDedLine3Change); void onDedLine4Change(char* newValue) { line4 = (newValue); } DcsBios::StringBuffer<25> dedLine4Buffer(0x454a, onDedLine4Change); void onDedLine5Change(char* newValue) { line5 = (newValue); } DcsBios::StringBuffer<25> dedLine5Buffer(0x4564, onDedLine5Change); void setup() { DcsBios::setup(); u8g2.begin(); u8g2.clearBuffer(); u8g2.setFont(u8g2_font_t0_12_tf); } void loop() { u8g2.firstPage(); do { u8g2.drawStr(0, 10, line1); u8g2.drawStr(0, 20, line2); u8g2.drawStr(0, 30, line3); u8g2.drawStr(0, 40, line4); u8g2.drawStr(0, 50, line5); } while ( u8g2.nextPage() ); u8g2.updateDisplay(); DcsBios::loop(); }
  7. thank you for your help but that didn't work either, but I did spot in your code that the "newValue" in line 5 has brackets around it and none of the other lines do as seen below, so I added brackets to the other 4 lines and it is now working, thanks again void onDedLine4Change(char* newValue) { line4 = newValue; } DcsBios::StringBuffer<25> dedLine4Buffer(0x454a, onDedLine4Change); void onDedLine5Change(char* newValue) { line5 = (newValue);
  8. I'm trying this on a mega2560 but just getting a blank screen, everything works with the test code from buydisplay web site, just wondering if anyone had any idea to why I get nothing on screen, dcs is running with f-16 sat hot start and dcsbios is reporting data coming in from the ded, I'm stumped
  9. I was trying this last week and getting the same result, I was going to post in here like you have done but you saved me a job, tks, I have no solution yet either, if you look at the DCSBios control reference for the AV-8B UFC it also shows comm 1&2 having : as the result coming from the code
  10. I'm just starting with this lot really and had a break over the last 3 months but these aer just experiments right now, I have managed to get some rgb oled displays like the one above to experiment with, being rgb you can have any colour you want, but for now here is what I have, I'll post the sketches up when I have time so others can refine them, one down fall so far is an f-16 font, can't find one around ready to use.
  11. see here https://forums.eagle.ru/topic/260156-latest-ob-27th-jan-what-the-hell-happened-to-the-harrier-mfds-other-players-especially-vr-think-its-an-issue/?tab=comments#comment-4552819
  12. It was reported during testing, but sometimes there are much more high priority or important issues that the developers need to address first, in my case I have the MPCD's exported to another monitor and those displays are pin sharp, the map display is a little harder to read but the data on it can now be changed in colour to help readability.
  13. you are lucky, with multi-monitor setup I get this blurred text, a few others reporting this too
  14. @Flappie, even our servers that run missions without the likes of moose, mist and ctld just mission editor stuff are crashing, logs have been provided in closed beta discussion thread, and yes guys we do test on a multiplayer server with massive amounts of units to stress test before release, but unfortunately we had no crash on client connect during the testing, which as many of you server owners know right now it can crash every 5 mins or run for a few hours first :thumbup:
  15. hope someone can make use of this 020-11-12 00:55:47.707 INFO NET: accepting connection from 73.149.75.210:55280 2020-11-12 00:55:47.710 INFO NET: adding client[3] 2020-11-12 00:55:47.774 INFO NET: added client[3] name=BreadFarmer addr=73.149.75.210:55280 2020-11-12 00:55:47.777 INFO LuaNET: SLMOD INFO: connected client 3 2020-11-12 00:55:47.777 INFO LuaNET: SLMOD INFO: num clients: 3 2020-11-12 00:55:47.777 INFO LuaNET: [LOTATC] Player connect: 73.149.75.210 2020-11-12 00:55:47.777 INFO LuaNET: [LOTATC] Player connect done 2020-11-12 00:55:47.780 INFO EDCORE: try to write dump information 2020-11-12 00:55:47.780 ERROR Lua::Config: Call error onPlayerConnect:[string "./MissionEditor/modules/mul_select_role.lua"]:734: bad argument #1 to 'pairs' (table expected, got string) stack traceback: [C]: ? [C]: in function 'pairs' [string "./MissionEditor/modules/mul_select_role.lua"]:734: in function 'updateGrids' [string "./MissionEditor/modules/mul_select_role.lua"]:447: in function 'onPlayerConnect' [string "./MissionEditor/GameGUI.lua"]:697: in function <[string "./MissionEditor/GameGUI.lua"]:695> (tail call): ? (tail call): ?. 2020-11-12 00:55:47.781 INFO EDCORE: # -------------- 20201112-005548 -------------- 2020-11-12 00:55:47.782 INFO EDCORE: DCS/2.5.6.57530 (x86_64; Windows NT 10.0.18363) 2020-11-12 00:55:47.783 INFO EDCORE: C:\WINDOWS\SYSTEM32\ntdll.dll 2020-11-12 00:55:47.784 INFO EDCORE: # C0000028 An invalid or unaligned stack was encountered during an unwind operation. at B0C5BE48 00:00000000 2020-11-12 00:55:47.786 INFO EDCORE: SymInit: Symbol-SearchPath: '.;C:\Program Files\Eagle Dynamics\DCS World OpenBeta;C:\Program Files\Eagle Dynamics\DCS World OpenBeta\bin;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'Dani' 2020-11-12 00:55:47.787 INFO EDCORE: OS-Version: 10.0.18363 () 0x100-0x1 dcs.log.zip
×
×
  • Create New...