Jump to content

[CORRECT AS-IS] CCIP Bugged?


Stearmandriver
 Share

Recommended Posts

Hi, 

 

I'm posting this as a question because while I've seen references to it, I can't find what - if anything - was ever confirmed.  I've noticed lately while CCIP bombing that the drop line and cross are varying degrees of "crooked", instead of hanging straight down from the VV.  This unsurprisingly leads to significant misses. 

 

1.  Has ED acknowledged this is a bug?

 

2.  I've read it's related to bad INS alignment on carriers.  Every time I've seen it, I've done a hot start on a carrier.  Are there known conditions under which this occurs and thus a known way to avoid it? 

 

Thanks.  Smart weapons are fun but it's also nice to be a pilot once in a while ;).

Link to comment
Share on other sites

If gps is available IFA will solve the issue. If gps is not available then you will need to perform updates regularly or just change the position from INS to TCN so you have a constant source of update (each 90 seconds).

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

I am finding the CCIP piper to be very inaccurate.

 

1. After lining up the fall line on the target, and right as the cross comes over the target, the piper will sometimes jump significantly. Even with AGR mode selected.

 

2. Any minor tilt - less than 1 degrees of AOB, and the bomb falls way off regardless if the piper is actually over the target. I thought the point of a continuously computed impact point was to correct and show where the bomb will land, even with some minor AOB dialed in. 

 

3. I also find bombs seem to always fall short - the heavier the bomb the more I have to compensate with the piper past the target to get the bomb on target.

 

I know its supposed to be hard, but this seems erratic. I used to be able to hit vehicles easily with Mark 82s, Not so much anymore.

:pilotfly: Specs: I9-9900k; ROG Strix RTX 2080ti; Valve Index HMD; 32GB DDR4 3200 Ram; Samsung 970 EVO 1TB SSD; TM Warthog with pedals, 3 TM MFDs

Link to comment
Share on other sites

14 minutes ago, Nagilem said:

I am finding the CCIP piper to be very inaccurate.

 

1. After lining up the fall line on the target, and right as the cross comes over the target, the piper will sometimes jump significantly. Even with AGR mode selected.

 

2. Any minor tilt - less than 1 degrees of AOB, and the bomb falls way off regardless if the piper is actually over the target. I thought the point of a continuously computed impact point was to correct and show where the bomb will land, even with some minor AOB dialed in. 

 

3. I also find bombs seem to always fall short - the heavier the bomb the more I have to compensate with the piper past the target to get the bomb on target.

 

I know its supposed to be hard, but this seems erratic. I used to be able to hit vehicles easily with Mark 82s, Not so much anymore.

 

Are you taking off from a moving carrier? Can you post a track of what you see?

 

I also would like to understand these aspects.


Edited by Joni
  • Like 1

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

7 hours ago, Joni said:

If gps is available IFA will solve the issue. If gps is not available then you will need to perform updates regularly or just change the position from INS to TCN so you have a constant source of update (each 90 seconds).

My flights are always warm starts on the supercarrier in the interest of time.  IFA is already selected, and augmented INS is displayed on the HSI.

 

Doesn't seem like using IFA helps at all. 

Link to comment
Share on other sites

3 minutes ago, Stearmandriver said:

My flights are always warm starts on the supercarrier in the interest of time.  IFA is already selected, and augmented INS is displayed on the HSI.

 

Doesn't seem like using IFA helps at all. 

 

What are you seeing exactly? I don't have problems with carrier warm or cold as long as there is GPS available and you are using Aided INS.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

1 hour ago, Joni said:

 

What are you seeing exactly? I don't have problems with carrier warm or cold as long as there is GPS available and you are using Aided INS.

The suspected bug I'm seeing, you mean?  Mainly, the fact that the CCIP drop line and cross are "crooked".  In straight and level flight, the drop line should extend vertically straight downwards from the velocity vector.  I've seen the drop line vary from just a few degrees off vertical to being more horizontal than vertical, when straight and level.  This leads to significant misses, as you'd expect.  I've also seen the airplane symbol on the HSI rotate up to about 60 degrees away from the normal "twelve o'clock" orientation.  It would not have occurred to me that these were related, but maybe so. 

 

As far as how the INS is configured - IFA is selected, and AINS is annunciated on HSI.

 

The relationship to carrier starts is interesting; I would not have thought of that.  But I stopped using CCIP a little while back because of this, then hoped the last update fixed it so I did some testing and it seemed to work, so I used it in a mission and it failed again.  The interesting thing is, when I tested it I used an air start scenario.  The times I've seen problems, it's always been off a boat. 

  • Like 1
Link to comment
Share on other sites

2 minutes ago, Stearmandriver said:

The suspected bug I'm seeing, you mean?  Mainly, the fact that the CCIP drop line and cross are "crooked".  In straight and level flight, the drop line should extend vertically straight downwards from the velocity vector.  I've seen the drop line vary from just a few degrees off vertical to being more horizontal than vertical, when straight and level.  This leads to significant misses, as you'd expect.  I've also seen the airplane symbol on the HSI rotate up to about 60 degrees away from the normal "twelve o'clock" orientation.  It would not have occurred to me that these were related, but maybe so. 

 

As far as how the INS is configured - IFA is selected, and AINS is annunciated on HSI.

 

The relationship to carrier starts is interesting; I would not have thought of that.  But I stopped using CCIP a little while back because of this, then hoped the last update fixed it so I did some testing and it seemed to work, so I used it in a mission and it failed again.  The interesting thing is, when I tested it I used an air start scenario.  The times I've seen problems, it's always been off a boat. 

 

Yes ok, the moving carrier alignment is broken but with Aided INS it seemed to work.

 

Maybe the moving carrier bug doesn't only affect the position the INS think it has but also the 3D space orientation, hence the weapon delivery issues.

 

But I don't know for sure, all the evidence I've seen of this was with no GPS available.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

Interesting, thanks for the responses.  Seems like it's likely related, so as long as ED is aware I guess that's the best we can do. 

 

Here's a screenshot of the last time I tried it.  The problem is not as pronounced as I've seen it, but you get the idea.  You can see we're in a mostly wings-level dive (very slightly left wing low), and the CCIP symbology is deflected to the right.  Impact point was far left of target. 

Screenshot_20201209-162702_Twitch.jpg

Link to comment
Share on other sites

28 minutes ago, Stearmandriver said:

Interesting, thanks for the responses.  Seems like it's likely related, so as long as ED is aware I guess that's the best we can do. 

 

Here's a screenshot of the last time I tried it.  The problem is not as pronounced as I've seen it, but you get the idea.  You can see we're in a mostly wings-level dive (very slightly left wing low), and the CCIP symbology is deflected to the right.  Impact point was far left of target. 

Screenshot_20201209-162702_Twitch.jpg

 

I don't think that line position is necessary wrong. Did you drop and miss? 

 

I'm gonna try some tests tonight and see if I can come up with something clear.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

1 hour ago, Joni said:

 

I don't think that line position is necessary wrong. Did you drop and miss? 

 

I'm gonna try some tests tonight and see if I can come up with something clear.

Yeah, pickled when the cross reached the beginning of the tank farm, and impacts were well to the left, where it makes sense to me that the cross would/should have been tracking in this case.  I'll see if I can do some tests too... I'd be interested to see what you come up with, thanks. 


Edited by Stearmandriver
Link to comment
Share on other sites

23 hours ago, Stearmandriver said:

Yeah, pickled when the cross reached the beginning of the tank farm, and impacts were well to the left, where it makes sense to me that the cross would/should have been tracking in this case.  I'll see if I can do some tests too... I'd be interested to see what you come up with, thanks. 

 

So I just asked a friend @heroe to make a cold start from a moving carrier test to see the CCIP and he got good results with it, no issues.

 

When I'm able to, I'll try it myself.

 

 

Thanks.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

Thanks... I made a couple tests last night myself; warm starts from a moving carrier (the scenario I've seen problems).  Worked fine both times for me too.

 

The only idea I currently have is:  when I've seen these problems, it's always been in a DCS Liberation mission.  Fairly complex missions multiple front lines, many flights starting immediately at mission start, no culling.  My machine seems to handle this ok - I rarely if ever see stutters or frame drops below about 50fps - but I wonder if all the scripts firing at once at mission start, with all the performance demands, are somehow bugging INS alignment or something else? 

 

TBH, I'm wondering how this could really be attributed to an INS alignment problem in the first place.  All other attitude instrumentation and position data seems accurate, so how could ONLY the CCIP symbology be affected by an INS misalignment? 

Link to comment
Share on other sites

1 minute ago, Stearmandriver said:

TBH, I'm wondering how this could really be attributed to an INS alignment problem in the first place.  All other attitude instrumentation and position data seems accurate, so how could ONLY the CCIP symbology be affected by an INS misalignment? 

 

DCS bugs are very complex too, and annoying as hell XD.

 

Come back and tell us if you see this issue again.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

I'm still having this same issue.  I always start from a moving carrier and have gotten the same HSI messages as seen on here (TODAY), doing the alignment then switching the the NAV mode.  I've tried switching to the IFA and no luck, my fall line is still at that odd 30 degree angle.  This has been happening to me for the last 2 updates or so.

ASUS ROG Strix Helios Case - ASUS AM4 ROG Strix X-570E MB - AMD Ryzen 5 3600 - 64 GB DDR4 3200 G.SKILL Ripjaws V Series - ASUS DualGeForce GTX 1070 - SSD 2x 1TB - HDD 10 TB - Windows 10 Home -

Thrustmaster Warthog HOTAS - Thrustmaster TPR Pedels - TrackIR

Link to comment
Share on other sites

I tried this yesterday and had no issues at all.

 

Track would be nice to see the issue.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

well got it to work after leaving my MOA. I guess I had to take it out of master arm and deselect AG as well as having IFA selected.  Ill have to try it sooner and see if that works or if it takes time to take effect now

 

ASUS ROG Strix Helios Case - ASUS AM4 ROG Strix X-570E MB - AMD Ryzen 5 3600 - 64 GB DDR4 3200 G.SKILL Ripjaws V Series - ASUS DualGeForce GTX 1070 - SSD 2x 1TB - HDD 10 TB - Windows 10 Home -

Thrustmaster Warthog HOTAS - Thrustmaster TPR Pedels - TrackIR

Link to comment
Share on other sites

53 minutes ago, CHSStarKiller said:

well got it to work after leaving my MOA. I guess I had to take it out of master arm and deselect AG as well as having IFA selected.  Ill have to try it sooner and see if that works or if it takes time to take effect now

 

 

If there is GPS available, having IFA selected isn't a solution but the correct procedure.

 

Anyway, I do think that pure INS is bugged, as having it in NAV mode should not make the weapon solutions go crazy.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

  • Wags changed the title to [MISSING TRACK FILE] CCIP Bugged?

Question, how do you know if GPS is available? Is that something added?

ASUS ROG Strix Helios Case - ASUS AM4 ROG Strix X-570E MB - AMD Ryzen 5 3600 - 64 GB DDR4 3200 G.SKILL Ripjaws V Series - ASUS DualGeForce GTX 1070 - SSD 2x 1TB - HDD 10 TB - Windows 10 Home -

Thrustmaster Warthog HOTAS - Thrustmaster TPR Pedels - TrackIR

Link to comment
Share on other sites

45 minutes ago, CHSStarKiller said:

Question, how do you know if GPS is available? Is that something added?

 

If putting the switch in NAV gives you an advisory of POS then GPS is available.

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

8 hours ago, Tholozor said:

The advisory will appear as 'P/INS'.

 

Yeah correct, I didn't remember how it was at the time of writting the post and I wanted to help the guy on his questions.

 

Thanks for clarifying!


Edited by Joni

Intel Core i5-8600k + Cooler Master Hyper 212 EVO | Gigabyte GTX 1070 Aorus 8G | 32GB DDR4 Corsair Vengance LPX Black 3200MHz | Gigabyte Z370 Aorus Gaming 3 | WD Black SN750 NVMe 500GB | Samsung 850 EVO 250GB | WD Green 240GB | WD Caviar Black 1TB SATA 3 | WD Caviar Blue 500GB SATA 3 | EVGA 650 GQ 80+ Gold | Samsung CF391 Curved 32" | Corsair 400C | Steelseries Arctis 5 --- Razer Kraken X Lite | Logitech G305 | Redragon Dyaus 2 K509 | Xbox 360 | Saitek X-52 Pro | Thrustmaster TWCS | TrackIR 5

Link to comment
Share on other sites

  • NineLine changed the title to [CORRECT AS-IS] CCIP Bugged?
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...