Jump to content

Version .6192 high rof gun crash introduced.


Flanker15
 Share

Recommended Posts

I've never had crashes up to this version but now whenever a high rof gun fires a long burst there's a good chance of getting booted back to the menu.

 

I've seen it happen:

Multiple times during a Uh-1 minigun burst.

When I fired a long burst in a shilka.

During an A-10 strafe .

During several ZSU stationary guns firing at once.

 

three crash logs:

 

# -------------- 20121007-082006 --------------

# C0000005 ACCESS_VIOLATION at 3FE66FA7 00:00000000
00000000 00000000 0000:00000000 
3FE66FA7 0018ED60 0000:00000000 
3FE5177C 0018EFF0 0000:00000000 
3FFD561D 0018F030 0000:00000000 
FB3A8721 0018F0C0 0000:00000000 
FB3A8BEA 0018F110 0000:00000000 
4009A079 0018F1A0 0000:00000000 
4009C10D 0018F200 0000:00000000 
400B3224 0018F230 0000:00000000 
400B3119 0018F290 0000:00000000 
401379F8 0018F300 0000:00000000 
40138E40 0018F7F0 0000:00000000 
4013B81F 0018F8A0 0000:00000000 
773C652D 0018F8D0 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D
779BC521 0018F920 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21


# -------------- 20121007-051722 --------------

# C0000005 ACCESS_VIOLATION at EF332A94 00:00000000
00000000 00000000 0000:00000000 
EF332A94 0013E800 0000:00000000 
EF33A90C 0013EAC0 0000:00000000  ??4GraphicEffect_Impl@Effects@@QEAAAEAV01@AEBV01@@Z()+19AC
F1795B94 0013EAF0 0000:00000000  ?DrawNormalLights@DXRenderer@Graphics@@AEAAXPEAPEAVRenderObject@2@H@Z()+A4
F179821D 0013EB30 0000:00000000  ?DrawObjects@DXRenderer@Graphics@@UEAAXPEAPEAVRenderObject@2@I@Z()+15D
F161DE91 0013EB80 0000:00000000  ?DrawTransparent@RenderParserImpl@@QEAAX_N0MM0@Z()+1D1
F162F6CB 0013EE40 0000:00000000  ?RenderScene@SceneManager_Implement@@QEAAXPEAVsmCamera@@_N@Z()+3DB
F163201A 0013EF60 0000:00000000  ?RenderMain@SceneManager_Implement@@UEAAXAEBVdPosition@@W4vCameraType_e@@AEBUViewport@smSceneManager@@@Z()+48A
F1633123 0013F170 0000:00000000  ?Render@SceneManager_Implement@@UEAAXXZ()+5D3
3FDBA13B 0013F200 0000:00000000 
3FDBC10D 0013F260 0000:00000000 
3FDD3224 0013F290 0000:00000000 
3FDD3119 0013F2F0 0000:00000000 
3FE579F8 0013F360 0000:00000000 
3FE58E40 0013F850 0000:00000000 
3FE5B81F 0013F900 0000:00000000 
773C652D 0013F930 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D
779BC521 0013F980 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21


# -------------- 20121007-045732 --------------

# C0000005 ACCESS_VIOLATION at EEAA2A94 00:00000000
00000000 00000000 0000:00000000 
EEAA2A94 0023E770 0000:00000000 
EEAAA90C 0023EA30 0000:00000000  ??4GraphicEffect_Impl@Effects@@QEAAAEAV01@AEBV01@@Z()+19AC
F1345B94 0023EA60 0000:00000000  ?DrawNormalLights@DXRenderer@Graphics@@AEAAXPEAPEAVRenderObject@2@H@Z()+A4
F134821D 0023EAA0 0000:00000000  ?DrawObjects@DXRenderer@Graphics@@UEAAXPEAPEAVRenderObject@2@I@Z()+15D
F5D9DE91 0023EAF0 0000:00000000  ?DrawTransparent@RenderParserImpl@@QEAAX_N0MM0@Z()+1D1
F5DAF6CB 0023EDB0 0000:00000000  ?RenderScene@SceneManager_Implement@@QEAAXPEAVsmCamera@@_N@Z()+3DB
F5DB201A 0023EED0 0000:00000000  ?RenderMain@SceneManager_Implement@@UEAAXAEBVdPosition@@W4vCameraType_e@@AEBUViewport@smSceneManager@@@Z()+48A
F5DB3123 0023F0E0 0000:00000000  ?Render@SceneManager_Implement@@UEAAXXZ()+5D3
3F70A13B 0023F170 0000:00000000 
3F70C10D 0023F1D0 0000:00000000 
3F723224 0023F200 0000:00000000 
3F723119 0023F260 0000:00000000 
3F7A79F8 0023F2D0 0000:00000000 
3F7A8E40 0023F7C0 0000:00000000 
3F7AB81F 0023F870 0000:00000000 
773C652D 0023F8A0 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D
779BC521 0023F8F0 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21


Edited by Flanker15
Link to comment
Share on other sites

I had issues when I updated to the latest Video Drivers for my 6950 2Gig ver. card. I went back to the older ver. and they went away.

 

I understand you did not have this issure before, remember there are graphics inhancements in this new ver.

 

Post specs of your PC also.

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

Same here. In my case it also happens when AI F/A-18s strafe targets with their guns while being visible in the screen or the TGP. Happened to me 3 times in a row on the A-10c campaign mission 4 (attrite some tank company) so I tried to finish the mission as quick as I can before the AI begins strafing with their guns.

 

Dunno if it's related but I'm also dumped back to the launcher screen occasionally when explosions are seen on TGP.

 

i5 2500k @4GHz

470 GTX

4GB DDR3 @1600cas9

 

I attached some of my crash logs. I'm pretty sure all except the latest log is for the gun effects crash while the last one is for the explosion on TGP effect.

Crash Logs.zip


Edited by MarkuzJuniuz
Attached crash logs.

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

also causes MP Issues with users getting disconnected (possibly saying they are disconnected because of the above crash).

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, R7970 Lightning @ 1.2 / 6 GHz Memory

3x ASUS VS248HP + Oculus HMD, Thrustmaster Warthog HOTAS + MFDs

Link to comment
Share on other sites

Anyone still getting the same crashes with the latest patch? Last time I looked it's 6288? I'm actually surprised at how smooth it was (or maybe it's just because I turned off labels) and that seeing seeing explosions of CBU-97s and a barrage of guns on the TGP no longer crashes my game.

 

Tested a few times on the Shooting Gallery mission.

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

Has happened to me twice, very random. Version 6288. Each crash was after a long gun burst with the A10.

 

Also, 6288 brought back the stutter-load on mission start in the A10 for me. P51 and KA50 does not have this issue.

 

Strange. Anyway, the difference I had was I reinstalled World from scratch and updated straight to 6288. Better stability and frame rate afterwards. The intense stutter during mission start after clicking the unpause button was also gone. Maybe reinstallation from a blank state helped?

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

I'll give that a try.

 

EDIT: Uninstalled, re-installed. Updated to 6288. Stutter-load with A10 is still present, game is installed on an SSD. KA50, P51 do not stutter-load missions, just the A10 still. Haven't been able to do enough testing for burst gun run crash yet....

 

Frame rate is still the same (great) until an explosion happens. Fly around at 60fps, then start doing stuff at 5-30fps.


Edited by Quirkitized
Link to comment
Share on other sites

I'll give that a try.

 

EDIT: Uninstalled, re-installed. Updated to 6288. Stutter-load with A10 is still present, game is installed on an SSD. KA50, P51 do not stutter-load missions, just the A10 still. Haven't been able to do enough testing for burst gun run crash yet....

 

Frame rate is still the same (great) until an explosion happens. Fly around at 60fps, then start doing stuff at 5-30fps.

 

Man, your PC has like double the power of mine yet the last time I tested my framerates are 40 to 70+! My settings are all on HIGH except Civilian Traffic to OFF, view distance to 60000, no labels. I'll do more tests, it might just be that the Shooting Gallery mission is very kind (but it crashed a lot before).

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

Sadly, I too just encountered this bug ( v6288 ).

 

Very easy to reproduce - fire a long burst and see how soon the game will crash on you. I have a feeling it has something to do with the new impact effects.

 

CBU's kill my FPS for brief period every time there are lots of multiple explosions around.

 

---

 

Specs:

 

i5 2500k @ 4.5 GHz

GTX 580 (driver version 301.42)

2x4 GB RAM

game installed on SSD

P8Z68 | 2500k @ 4.5 | GTX 1080Ti | 2x8 GB @ 1600 | TM Hog (extended 7cm) & MFG Crosswind (S/N 007) | TIR v5

WWII bomber formations | DCS P-51D: [TEST] TO distance / gross weight / temperature

Link to comment
Share on other sites

1.2.1 6288 ran smooth for me until now.

 

But today I made a bad landing and the P-51 blew up, but laso Crashed to desktop with the following log:

 

# -------------- 20121011-154505 --------------

C:\Spil Finn\DCS World\bin\NGModel.dll

# C0000005 ACCESS_VIOLATION at 10B2FF38 01:0000EF38

#

# EAX = 00000000

# EBX = 000002EC

# ECX = 00044550

# EDX = 00000000

# ESI = 20E04FB8

# EDI = 00000015

# CS:EIP = 001B:10B2FF38

# SS:ESP = 0023:0F63F6EC EBP = 00000011

# DS = 0023 ES = 0023 FS = 003B GS = 0000

# Flags = 00010206

 

Here is the dcs.log:

dcs.zip

 

Yesteday I got a CTD in multiplayer with this log:

 

C:\Spil Finn\DCS World\bin\Effects.dll

# C0000005 ACCESS_VIOLATION at 02E2B980 01:0000A980

#

# EAX = 00000028

# EBX = 0012F5CC

# ECX = 0000000A

# EDX = 0000270F

# ESI = 0012F5CC

# EDI = 00000028

# CS:EIP = 001B:02E2B980

# SS:ESP = 0023:0012F55C EBP = 0012F5AC

# DS = 0023 ES = 0023 FS = 003B GS = 0000

# Flags = 00010206

i7-10700K 3.8-5.1Ghz, 32GB RAM, RTX 2070 Super 8GB, 2 x 1 TB SSD, 2 TB HDD 7200 RPM, Win10 Home 64bit.

Link to comment
Share on other sites

Had 2 crashes today which is unusual (havn't had random crashes in a while)

 

Happend in MP after arround 20+ minutes

 

# -------------- 20121011-153808 --------------

 

# C0000005 ACCESS_VIOLATION at E47535DD 00:00000000

00000000 00000000 0000:00000000

E47535DD 002FEE20 0000:00000000

E47826D0 002FEF10 0000:00000000

E735A2AD 002FEF50 0000:00000000 ??1Reader@Mail@@UEAA@XZ()+23D

E44494B4 002FEFC0 0000:00000000

E4449561 002FF010 0000:00000000

E444370E 002FF040 0000:00000000

E446C953 002FF070 0000:00000000

E4482C83 002FF0A0 0000:00000000

3FF3C1A5 002FF100 0000:00000000

3FF532B4 002FF130 0000:00000000

3FF531A9 002FF190 0000:00000000

3FFD8098 002FF200 0000:00000000

3FFD94D8 002FF6F0 0000:00000000

3FFDBEBF 002FF7A0 0000:00000000

7768652D 002FF7D0 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D

778BC521 002FF820 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21

 

# -------------- 20121011-165042 --------------

 

# C0000005 ACCESS_VIOLATION at E4E935DD 00:00000000

00000000 00000000 0000:00000000

E4E935DD 0024F5C0 0000:00000000

E4EC26D0 0024F6B0 0000:00000000

E70FA2AD 0024F6F0 0000:00000000 ??1Reader@Mail@@UEAA@XZ()+23D

E4B094B4 0024F760 0000:00000000

E4B09561 0024F7B0 0000:00000000

E4B0370E 0024F7E0 0000:00000000

E4B2C953 0024F810 0000:00000000

E4B42C83 0024F840 0000:00000000

3FF0C1A5 0024F8A0 0000:00000000

3FF232B4 0024F8D0 0000:00000000

3FF231A9 0024F930 0000:00000000

3FFA8098 0024F9A0 0000:00000000

3FFA94D8 0024FE90 0000:00000000

3FFABEBF 0024FF40 0000:00000000

7768652D 0024FF70 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D

778BC521 0024FFC0 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I spoke too soon. 6288 crash with a long gun burst, Free Flight.

 

# -------------- 20121012-032057 --------------

# C0000005 ACCESS_VIOLATION at ECBE2C52 00:00000000
00000000 00000000 0000:00000000 
ECBE2C52 0014E9E0 0000:00000000 
ECBEA90C 0014ECA0 0000:00000000  ??4GraphicEffect_Impl@Effects@@QEAAAEAV01@AEBV01@@Z()+19AC
ED6F5B94 0014ECD0 0000:00000000  ?DrawNormalLights@DXRenderer@Graphics@@AEAAXPEAPEAVRenderObject@2@H@Z()+A4
ED6F821D 0014ED10 0000:00000000  ?DrawObjects@DXRenderer@Graphics@@UEAAXPEAPEAVRenderObject@2@I@Z()+15D
ED06DD81 0014ED60 0000:00000000  ?DrawTransparent@RenderParserImpl@@QEAAX_N0MM0@Z()+C1
ED07F6CB 0014F020 0000:00000000  ?RenderScene@SceneManager_Implement@@QEAAXPEAVsmCamera@@_N@Z()+3DB
ED08201A 0014F140 0000:00000000  ?RenderMain@SceneManager_Implement@@UEAAXAEBVdPosition@@W4vCameraType_e@@AEBUViewport@smSceneManager@@@Z()+48A
ED083123 0014F350 0000:00000000  ?Render@SceneManager_Implement@@UEAAXXZ()+5D3
3F6F950B 0014F3E0 0000:00000000 
3F6FC22D 0014F440 0000:00000000 
3F7132B4 0014F470 0000:00000000 
3F7131A9 0014F4D0 0000:00000000 
3F798098 0014F540 0000:00000000 
3F7994D8 0014FA30 0000:00000000 
3F79BEBF 0014FAE0 0000:00000000 
765E652D 0014FB10 0001:0001552D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D
76CDC521 0014FB60 0001:0002B521 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

Same here, long burst with the A-10 gun (damn T-80s :D) causing a CTD for me and everyone in close proximity. Same logs, pasting just in case :

 

# -------------- 20121010-201137 --------------

 

# C0000005 ACCESS_VIOLATION at E7722A94 00:00000000

00000000 00000000 0000:00000000

E7722A94 002FEC70 0000:00000000

E772A90C 002FEF30 0000:00000000 ??4GraphicEffect_Impl@Effects@@QEAAAEAV01@AEBV01@@Z()+19AC

EA075B94 002FEF60 0000:00000000 ?DrawNormalLights@DXRenderer@Graphics@@AEAAXPEAPEAVRenderObject@2@H@Z()+A4

EA07821D 002FEFA0 0000:00000000 ?DrawObjects@DXRenderer@Graphics@@UEAAXPEAPEAVRenderObject@2@I@Z()+15D

E99DDD81 002FEFF0 0000:00000000 ?DrawTransparent@RenderParserImpl@@QEAAX_N0MM0@Z()+C1

E99EF6CB 002FF2B0 0000:00000000 ?RenderScene@SceneManager_Implement@@QEAAXPEAVsmCamera@@_N@Z()+3DB

E99F201A 002FF3D0 0000:00000000 ?RenderMain@SceneManager_Implement@@UEAAXAEBVdPosition@@W4vCameraType_e@@AEBUViewport@smSceneManager@@@Z()+48A

E99F3123 002FF5E0 0000:00000000 ?Render@SceneManager_Implement@@UEAAXXZ()+5D3

4023950B 002FF670 0000:00000000

4023C22D 002FF6D0 0000:00000000

402532B4 002FF700 0000:00000000

402531A9 002FF760 0000:00000000

402D8098 002FF7D0 0000:00000000

402D94D8 002FFCC0 0000:00000000

402DBEBF 002FFD70 0000:00000000

7734F33D 002FFDA0 0001:0001E33D C:\Windows\system32\kernel32.dll BaseThreadInitThunk()+D

77A42CA1 002FFDF0 0001:00031CA1 C:\Windows\SYSTEM32\ntdll.dll RtlUserThreadStart()+21

92nd Kodiak Air Force - May the Greuh be with you
Link to comment
Share on other sites

Well I think what you are seeing here is a result of trying Multithreading to

attempt to use multicores.

 

 

This is the holy grail everyone keeps asking for. Use of multicores for DCS World.

 

This brings its own set of problems with synchronization and waiting

on threads to complete before calling them again. Gets tricky. I know

because I have written such applications and when timing was off apps

would crash. Regardless of how many threads or cores you use you still

have to deal with synchronization.

 

Of course this is just a guess on my part but it would make sense that ED

would like to try these things in the field now that updates can easily be

applied and reversed.

 

 

Here is some links describing these things in more detail.

 

 

http://stackoverflow.com/questions/11235279/debugging-rtluserthreadstart-in-process-explorer

 

 

http://stackoverflow.com/questions/1103938/multithreaded-application-in-a-multicore-processor

I'd rather have a bottle in front of me than a frontal lobotomy and I've had both.

 

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

I got to minimize the crashing by setting Scenes to Medium. At High, 3/3 times it crashed when it seems like a giant dust cloud begins to form where the bullet hits the ground. At Medium it only crashed once in 5 attempts to empty the gun. I noticed that before the crash there's an instant wherein the building I peppered with guns became transparent on the TGP while some fires are beginning to form.

 

Seems like some effects are crashing the engine.


Edited by MarkuzJuniuz
Corrected Sentence

i5 2500K @ 4.2GHz | GTX 470 | 8GB DDR3 @ 1600

Link to comment
Share on other sites

We had the same issue (a-10) but it was someone else affected by it- server was on a LAN speed setting and he was on 512. Happened to him twice- then he bumped his speed up to LAN- then we couldn't duplicate it... Fired a full drum on the ground and in the air.

 

We haven't had the issue since.


Edited by ENO

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...