Jump to content

Problem with TM Warthog Throttle synchronisation


jfri
 Share

Recommended Posts

I have a TM Warthog HOTAS controller. When running the startup tutorial I see the throttle not being synchronized at start. I start the lesson with the throttle in cut off position which is also seen in the cockpit. But when I should start the engines by moving the throttle out of cut off to idle nothing happens. I must move the throttle back to idle cut off and the again to idle for things to start happening i.e both seeing the throttle in the cockpit moving and the engine starting. And yes I have ticked the synchronize cockpit controls with the HOTAS at start.

Link to comment
Share on other sites

I'm doing this from memory at work, so it's almost definitely not precise:

 

There's an option somewhere in your settings menu called "Syncronize HOTAS Controls" or something to that affect. Make sure that's checked. Most of the time I experience exactly what you're describing, that option is not turned on.

 

Double check that, and post back with your results.

Link to comment
Share on other sites

 

| i9 9900K Octa Core 2TB SSD +32GB Spectrix DDR4 @3200MHz RGB | 2 x Radeon RX480 in Crossfire. | TrackIR5 HOTAS Warthog,MFG Crosswind Pedals | Cougar MFDs |

 

[OCG] Oceanic Combat Group

discord.gg/ZmXEBSU

"Through The Inferno"

by deadlyfishes

 

Official Australian Servers

 

SRS: All Servers have Auto-Connect Enabled

 

Server 1: TTI Caucasus

Server 2: TTI Persian Gulf

Server 3: OCG Training

Server 4: OCG NTTR & Multiplayer Missions

 

Australian Website

AU Discord Server

Link to comment
Share on other sites

Go to MISCELLANEOUS under your OPTIONS. Check SYNCHRONIZE COCKPIT CONTROLS WITH HOTAS CONTROLS AT MISSION START.

[sIGPIC][/sIGPIC]WIN 10, i7 10700, 32GB DDR4, RTX 2080 Super, Crucial 1TB SSD, Samsung EVO 850 500GB SSD, TM Warthog with 10cm extension, TIR5, MFG Crosswind Pedals, Wheelstand Pro, LG 40" 4K TV, Razer Black Widow Ultimate KB[/size]

Link to comment
Share on other sites

I'm doing this from memory at work, so it's almost definitely not precise:

 

There's an option somewhere in your settings menu called "Syncronize HOTAS Controls" or something to that affect. Make sure that's checked. Most of the time I experience exactly what you're describing, that option is not turned on.

 

Double check that, and post back with your results.

 

As I sad in the post I am aware of that option and has it checked

Link to comment
Share on other sites

I am facing the same problem recently. The first unlocking of throttles doesn't work. I have to move them back into the off detent and then forward again to start the engine.

 

Do you like me have this problem even when you have checked SYNCHRONIZE COCKPIT CONTROLS WITH HOTAS CONTROLS AT MISSION START?

Link to comment
Share on other sites

Possible issue: Even with the controller calibrated and active in Windows, if you don't "wake it up" (after a restart, or coming out of sleep mode), it is sometimes not recognized in games until you move it around some... A Windows issue, not DCS...

 

Don't know if you already do, but maybe get in the habit of moving all your controllers through their maximum before you start the sim and see if that helps?

Link to comment
Share on other sites

Possible issue: Even with the controller calibrated and active in Windows, if you don't "wake it up" (after a restart, or coming out of sleep mode), it is sometimes not recognized in games until you move it around some... A Windows issue, not DCS...

 

If this is the case, a quick disconnect and reconnect before starting DCS should fix the problem as well. Though that could become rather tedious if you have to do it after every time you put your machine to sleep depending on how frequently your machine takes a nap.

Link to comment
Share on other sites

Also it stands contradicting to USB plug&play.

 

This problem occurs whenever I start a new A-10C. Shutting down the mission or even DCS didn't happen. Also it worked before. This issue came up after one of the latest patches...

Link to comment
Share on other sites

I've found synchronization to be quite finicky, in my case the A-10 works fine but all other modules start with the throttles fully forward and the stick full forward/left until I move them. You can imagine how frustrating this is with a hot start helicopter or an air start in a plane. Instead for the A-10 I leave the throttles forward, once I'm the cockpit I move them both into cut-off, they're then ready to go when I reach that point in the starting procedure.

Intel 9600K@4.9GHz, Asus Z390, 32GB DDR4, EVGA RTX 3070, Custom Water Cooling, 970 EVO 1TB NVMe

34" UltraWide 3440x1440 Curved Monitor, 21" Touch Screen MFD monitor, TIR5

My Pit Build, VKB Gunfighter Pro w/WH Grip, TMWH Throttle, MFG Crosswinds W/Combat Pedals, Cougar MFDs, Custom A-10C panels, Custom Helo Collective, SimShaker with Transducer

Link to comment
Share on other sites

I haven't had any of this problems with my Warthog but I will share how I'm using it.

 

I have latest firmware installed.

 

Also, I'm keeping it unplugged. I plugin usb connectors before starting DCS and unplug it after closing DCS. Somewhere I've found information that turning off and turning on computer while HOTAS is connected could cause permanent damage of HOTAS electronics. I'm not sure if this is true but I'm unplugging it just in case it is true.

 

...and I'm using USB 2.0 ports for Warthog.


Edited by marluk
[B]*NOB* Lucky[/B] [SIGPIC][/SIGPIC] Tko vrijedi leti, tko leti vrijedi, tko ne leti ne vrijedi
Link to comment
Share on other sites

Somewhere I've found information that turning off and turning on computer while HOTAS is connected could cause permanent damage of HOTAS electronics. I'm not sure if this is true but I'm unplugging it just in case it is true.

 

If so the product is seriously flawed, This shouldn't be a problem for an USB device.

I will check if my firmware is updated.

I use USB 3 ports but that shouldn't be a problem

Link to comment
Share on other sites

Also it stands contradicting to USB plug&play.

 

This problem occurs whenever I start a new A-10C. Shutting down the mission or even DCS didn't happen. Also it worked before. This issue came up after one of the latest patches...

 

If the problem arose just after DCS being patched it is an indication that the problem is with DCS itself. Maybe a new DCS patch is what we need ?

Link to comment
Share on other sites

If so the product is seriously flawed, This shouldn't be a problem for an USB device.

I will check if my firmware is updated.

I use USB 3 ports but that shouldn't be a problem

 

On the contrary, I use USB 2.0 ports for Warthog intentionally because those using USB 3.0 for Warthog have reported some problems because of that.

 

If you have possibility try to connect it on USB 2.0 port and check behavior again.

 

Firmware updating leave for last resort, those things are always little tricky.

 

Good luck.


Edited by marluk
[B]*NOB* Lucky[/B] [SIGPIC][/SIGPIC] Tko vrijedi leti, tko leti vrijedi, tko ne leti ne vrijedi
Link to comment
Share on other sites

On the contrary, I use USB 2.0 ports for Warthog intentionally because those using USB 3.0 for Warthog have reported some problems because of that.

 

If you have possibility try to connect it on USB 2.0 port and check behavior again.

 

Firmware updating leave for last resort, those things are always little tricky.

 

Good luck.

 

What problem ? I'm not sure but I think all my USB ports are USB 3. But I do have a powered USB hub with USB 2 ports

Link to comment
Share on other sites

If this is the case, a quick disconnect and reconnect before starting DCS should fix the problem as well. Though that could become rather tedious if you have to do it after every time you put your machine to sleep depending on how frequently your machine takes a nap.

 

:) All I'm suggesting is that you wiggle the stick a bit before you start the sim...

 

There is a setting deep within Windows that allows it to "turn off the USB" to save power. A little wiggle wakes it up, such as moving from off to idle and back to off...

 

Probably not this issue, but it never hurts to have information...

Link to comment
Share on other sites

:) All I'm suggesting is that you wiggle the stick a bit before you start the sim...

 

There is a setting deep within Windows that allows it to "turn off the USB" to save power. A little wiggle wakes it up, such as moving from off to idle and back to off...

 

Probably not this issue, but it never hurts to have information...

 

That didn't help

Link to comment
Share on other sites

Maybe remap Rctrl/RAlt+Home to detent?

AWAITING ED NEW DAMAGE MODEL IMPLEMENTATION FOR WW2 BIRDS

 

Fat T is above, thin T is below. Long T is faster, Short T is slower. Open triangle is AWACS, closed triangle is your own sensors. Double dash is friendly, Single dash is enemy. Circle is friendly. Strobe is jammer. Strobe to dash is under 35 km. HDD is 7 times range key. Radar to 160 km, IRST to 10 km. Stay low, but never slow.

Link to comment
Share on other sites

What problem ? I'm not sure but I think all my USB ports are USB 3. But I do have a powered USB hub with USB 2 ports

 

Here are some threads with discussions about Warthog and usb 3.0

 

http://forums.eagle.ru/showthread.php?t=118367&highlight=Warthog+usb

http://forums.eagle.ru/showthread.php?t=132159&highlight=Warthog+usb

http://forums.eagle.ru/showthread.php?t=142711&highlight=Warthog+usb

 

I'm not sure that Warthog on USB 3.0 causes problems but I'm using it on USB 2.0 and I haven't experienced any of your problems.

 

Check your motherboard documentation. Maybe you have connectors for usb 2.0 on the board. So you can buy only cables with holder for plugs. Generally MB have few unexposed usb connectors.


Edited by marluk
[B]*NOB* Lucky[/B] [SIGPIC][/SIGPIC] Tko vrijedi leti, tko leti vrijedi, tko ne leti ne vrijedi
Link to comment
Share on other sites

I had similar problems until I got it working every time.

 

1. UNCHECK the auto sync tickbox. It never works reliably.

 

2. Dont use the TARGET software that comes with the stick/throttle. It seems to merge the two devices and confuses DCS.

 

3. Start up DCS: A-10C and go to the controller setup ingame. Press all the buttons and check the axes. They should all auto map themself. Save the config.

 

4. Next time you play the game just go into the controls system and load the config and press one of the buttons to confirm the rest have loaded.

 

 

It's a hassle to do it every game launch but you probably spend hours in the cockpit which is a small percentage of time loading the config. Since doing it this way I get consistently mapped buttons and axes.

 

Regarding the blown motherboards in the Throttle I have a feeling it is the power draw for the lighting that is at fault (but don't quote me on that). To light up that box like a christmas tree I would have thought it would have needed an external PSU.

 

Hence why I turned off my green meenies... I'll probably mod in and external lighting circuit that I can link up to my pit's dashboards.

Link to comment
Share on other sites

I have a similar problem only with a twist... Every button works fine at the begining of the mission but after about an hour in the mission, it seems DCS forgot where I left the switch at.

 

For example, when coming for landing after an hour long mission, I lower the flaps 1 notch, nothing happens. I have to flip the flaps switch back up and down to MVR again for DCS to detect it. Very frustrating.

 

Oh and that is with or without sync hotas option ticked.

i5 4590 @ 3.77GHz | GTX 1060 6GB | 16GB 1600MHz DDR3 | 1TB HDD+500GB HDD | Win10 Home X64

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Here are some threads with discussions about Warthog and usb 3.0

 

http://forums.eagle.ru/showthread.php?t=118367&highlight=Warthog+usb

http://forums.eagle.ru/showthread.php?t=132159&highlight=Warthog+usb

http://forums.eagle.ru/showthread.php?t=142711&highlight=Warthog+usb

 

I'm not sure that Warthog on USB 3.0 causes problems but I'm using it on USB 2.0 and I haven't experienced any of your problems.

 

Check your motherboard documentation. Maybe you have connectors for usb 2.0 on the board. So you can buy only cables with holder for plugs. Generally MB have few unexposed usb connectors.

 

I tried an USB 2.0 port on my USB HUB. It didn't help.

Link to comment
Share on other sites

I tried an USB 2.0 port on my USB HUB. It didn't help.

 

I would try to play with USB bios options like Legacy USB Support, Controller mode...

It might help.

[B]*NOB* Lucky[/B] [SIGPIC][/SIGPIC] Tko vrijedi leti, tko leti vrijedi, tko ne leti ne vrijedi
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...